summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-21 15:50:30 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-21 15:50:30 +0000
commit6d649705eb405a77dcbead1b736d350f23e0943c (patch)
tree5a83de0382d4ead17db3b322e17c9b054246324a /dev-python/pydns
parenteapi5ifying sqlalchemy-migrate (diff)
downloadgentoo-2-6d649705eb405a77dcbead1b736d350f23e0943c.tar.gz
gentoo-2-6d649705eb405a77dcbead1b736d350f23e0943c.tar.bz2
gentoo-2-6d649705eb405a77dcbead1b736d350f23e0943c.zip
bumps; closes Bugs #473164, 473166
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pydns')
-rw-r--r--dev-python/pydns/ChangeLog12
-rw-r--r--dev-python/pydns/pydns-2.3.6-r1.ebuild54
-rw-r--r--dev-python/pydns/pydns-3.0.2-r1.ebuild51
3 files changed, 114 insertions, 3 deletions
diff --git a/dev-python/pydns/ChangeLog b/dev-python/pydns/ChangeLog
index 12ca6da4ab15..9ff14ea95a3d 100644
--- a/dev-python/pydns/ChangeLog
+++ b/dev-python/pydns/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pydns
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/ChangeLog,v 1.14 2012/06/24 12:22:55 sbriesen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/ChangeLog,v 1.15 2013/06/21 15:50:30 idella4 Exp $
+
+*pydns-3.0.2-r1 (21 Jun 2013)
+*pydns-2.3.6-r1 (21 Jun 2013)
+
+ 21 Jun 2013; Ian Delaney <idella4@gentoo.org> +pydns-2.3.6-r1.ebuild,
+ +pydns-3.0.2-r1.ebuild:
+ bumps; closes Bugs #473164, 473166
*pydns-3.0.2 (24 Jun 2012)
*pydns-2.3.6 (24 Jun 2012)
@@ -64,4 +71,3 @@
06 Oct 2006; Stefan Briesenick <sbriesen@gentoo.org> +metadata.xml,
+pydns-2.3.0.ebuild:
initial commit.
-
diff --git a/dev-python/pydns/pydns-2.3.6-r1.ebuild b/dev-python/pydns/pydns-2.3.6-r1.ebuild
new file mode 100644
index 000000000000..0a9c298ee029
--- /dev/null
+++ b/dev-python/pydns/pydns-2.3.6-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/pydns-2.3.6-r1.ebuild,v 1.1 2013/06/21 15:50:30 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for DNS (Domain Name Service)"
+HOMEPAGE="http://pydns.sourceforge.net/ http://pypi.python.org/pypi/pydns"
+SRC_URI="http://downloads.sourceforge.net/project/pydns/pydns/${P}/${P}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="!dev-python/pydns:0
+ virtual/libiconv"
+RDEPEND=""
+
+DOCS=( CREDITS )
+# Funny a dns package attempts to use the network on tests
+# Await the day that gentoo chills out on such a blanket law.
+RESTRICT=test
+
+python_prepare_all() {
+ # Fix encodings (should be utf-8 but is latin1).
+ for i in DNS/{Lib,Type}.py; do
+ iconv -f ISO-8859-1 -t UTF-8 < "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+
+ # Don't compile bytecode.
+ sed -i -e 's:^\(compile\|optimize\).*:\1 = 0:g' setup.cfg
+
+ # cleanup docs
+ rm -f -- "README-guido.txt"
+ mv -f -- "README.txt" "README"
+ mv -f -- "CREDITS.txt" "CREDITS"
+}
+
+python_test() {
+ local test
+ for test in tests/{test.py,test[2-5].py,testsrv.py}
+ do
+ "${PYTHON}" $test || die
+ done
+}
+
+python_install_all(){
+ use examples && local EXAMPLES=( ./{tests,tools}/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pydns/pydns-3.0.2-r1.ebuild b/dev-python/pydns/pydns-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..f4db50cc11cd
--- /dev/null
+++ b/dev-python/pydns/pydns-3.0.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/pydns-3.0.2-r1.ebuild,v 1.1 2013/06/21 15:50:30 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for DNS (Domain Name Service)"
+HOMEPAGE="http://pydns.sourceforge.net/ http://pypi.python.org/pypi/pydns"
+SRC_URI="http://downloads.sourceforge.net/project/pydns/py3dns/${P/py/py3}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="virtual/libiconv"
+#should this have !dev-python/pydns:0 ?
+RDEPEND=""
+
+DOCS=( CREDITS )
+# Funny a dns package attempts to use the network on tests
+# Await the day that gentoo chills out on such a blanket law.
+RESTRICT=test
+
+S="${WORKDIR}/${P/py/py3}"
+
+src_prepare() {
+ # Don't compile bytecode.
+ sed -i -e 's:^\(compile\|optimize\).*:\1 = 0:g' setup.cfg
+
+ # cleanup docs
+ rm -f -- "README-guido.txt"
+ mv -f -- "README.txt" "README"
+ mv -f -- "CREDITS.txt" "CREDITS"
+}
+
+python_test() {
+ local test
+ for test in tests/{test.py,test[2-5].py,testsrv.py}
+ do
+ "${PYTHON}" $test || die
+ done
+}
+
+python_install_all(){
+ use examples && local EXAMPLES=( ./{tests,tools}/. )
+ distutils-r1_python_install_all
+}