summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-07 20:11:49 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-07 20:11:49 +0000
commit05427dee6f1c8988835384f21e909b3a0606736b (patch)
treeb95b30c7225c049fe2da2848c9330ae824ab29d5 /dev-python/pyfits
parentBump to latest Linux-PAM version, use a newer Berkeley DB version, move to EA... (diff)
downloadgentoo-2-05427dee6f1c8988835384f21e909b3a0606736b.tar.gz
gentoo-2-05427dee6f1c8988835384f21e909b3a0606736b.tar.bz2
gentoo-2-05427dee6f1c8988835384f21e909b3a0606736b.zip
Version bump.
(Portage version: 14516-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyfits')
-rw-r--r--dev-python/pyfits/ChangeLog6
-rw-r--r--dev-python/pyfits/pyfits-2.2.1.ebuild33
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/pyfits/ChangeLog b/dev-python/pyfits/ChangeLog
index 3ad116b7c1bf..7e325565a8ca 100644
--- a/dev-python/pyfits/ChangeLog
+++ b/dev-python/pyfits/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyfits
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfits/ChangeLog,v 1.10 2009/09/30 19:42:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfits/ChangeLog,v 1.11 2009/10/07 20:11:49 arfrever Exp $
+
+ 07 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyfits-2.2.1.ebuild:
+ Version bump.
*pyfits-2.2 (30 Sep 2009)
diff --git a/dev-python/pyfits/pyfits-2.2.1.ebuild b/dev-python/pyfits/pyfits-2.2.1.ebuild
new file mode 100644
index 000000000000..595b19683884
--- /dev/null
+++ b/dev-python/pyfits/pyfits-2.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfits/pyfits-2.2.1.ebuild,v 1.1 2009/10/07 20:11:49 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Provides an interface to FITS formatted files under python"
+SRC_URI="http://www.stsci.edu/resources/software_hardware/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/pyfits"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+LICENSE="AURA"
+
+RDEPEND="dev-python/numpy"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ cd "${S}/test"
+
+ testing() {
+ local test
+ for test in test*.py; do
+ PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib*)" "$(PYTHON)" "${test}" || die "test ${test} failed with Python ${PYTHON_ABI}"
+ done
+ }
+ python_execute_function testing
+}