summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-04 13:06:18 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-04 13:06:18 +0000
commit5b8307324b76bdf8f466c4629a297c20016d808c (patch)
treeb5978dc04dbf73d3fa47e646206679f4fe6f58ca /dev-python/pygame/pygame-1.5.5.ebuild
parentnew version (diff)
downloadgentoo-2-5b8307324b76bdf8f466c4629a297c20016d808c.tar.gz
gentoo-2-5b8307324b76bdf8f466c4629a297c20016d808c.tar.bz2
gentoo-2-5b8307324b76bdf8f466c4629a297c20016d808c.zip
version bump
Diffstat (limited to 'dev-python/pygame/pygame-1.5.5.ebuild')
-rw-r--r--dev-python/pygame/pygame-1.5.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pygame/pygame-1.5.5.ebuild b/dev-python/pygame/pygame-1.5.5.ebuild
new file mode 100644
index 000000000000..32578a99bbe7
--- /dev/null
+++ b/dev-python/pygame/pygame-1.5.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.5.5.ebuild,v 1.1 2003/03/04 13:06:18 liquidx Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+SRC_URI="http://www.pygame.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.pygame.org/"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha"
+
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-ttf-2.0.5
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.4
+ >=dev-python/Numeric-22.0.0
+ >=media-libs/smpeg-0.4.4-r1"
+
+inherit distutils
+
+src_install () {
+ mydoc=WHATSNEW
+ distutils_src_install
+
+ dohtml -r docs/*
+ dodir /usr/share/doc/${PF}/examples
+ cp -r ${S}/examples ${D}usr/share/doc/${PF}/
+}
+