summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-02-28 18:06:08 +0000
committerPacho Ramos <pacho@gentoo.org>2015-02-28 18:06:08 +0000
commit1930f489ad972bc5b47e4fa0b9ef5b7e0973d436 (patch)
tree5f83d7b37c6a0c21faf68427b8bab9f41f59c3d1 /dev-python/pygame
parentVersion bump. (diff)
downloadgentoo-2-1930f489ad972bc5b47e4fa0b9ef5b7e0973d436.tar.gz
gentoo-2-1930f489ad972bc5b47e4fa0b9ef5b7e0973d436.tar.bz2
gentoo-2-1930f489ad972bc5b47e4fa0b9ef5b7e0973d436.zip
Workaround bug #516434 until a better fix is found (thanks to Markus Oehme), drop old.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog10
-rw-r--r--dev-python/pygame/files/pygame-1.9.2_pre20120101-import-bdist.patch49
-rw-r--r--dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild80
-rw-r--r--dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild9
4 files changed, 64 insertions, 84 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index 9e92069b9dd8..019b0be3626b 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygame
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.103 2014/11/24 15:03:26 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.104 2015/02/28 18:06:08 pacho Exp $
+
+ 28 Feb 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/pygame-1.9.2_pre20120101-import-bdist.patch,
+ -pygame-1.9.2_pre20120101-r1.ebuild, pygame-1.9.2_pre20120101-r2.ebuild:
+ Workaround bug #516434 until a better fix is found (thanks to Markus Oehme),
+ drop old.
24 Nov 2014; Pacho Ramos <pacho@gentoo.org>
pygame-1.9.2_pre20120101-r2.ebuild:
diff --git a/dev-python/pygame/files/pygame-1.9.2_pre20120101-import-bdist.patch b/dev-python/pygame/files/pygame-1.9.2_pre20120101-import-bdist.patch
new file mode 100644
index 000000000000..f587401ab25d
--- /dev/null
+++ b/dev-python/pygame/files/pygame-1.9.2_pre20120101-import-bdist.patch
@@ -0,0 +1,49 @@
+From f5ee3952769d698d7d03ae61a9c70f2ec4d85874 Mon Sep 17 00:00:00 2001
+From: "Markus (root)" <mo@wurzel.org>
+Date: Sun, 19 Oct 2014 16:56:41 +0200
+Subject: [PATCH] This fails with a TypeError, but offers no functionality.
+
+---
+ pygame-1.9.2_pre20120101-python3_3/setup.py | 26 +++++++++++++-------------
+ 1 file changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/pygame-1.9.2_pre20120101-python3_3/setup.py b/pygame-1.9.2_pre20120101-python3_3/setup.py
+index ecee5d1..b913f18 100644
+--- a/pygame-1.9.2_pre20120101-python3_3/setup.py
++++ b/pygame-1.9.2_pre20120101-python3_3/setup.py
+@@ -99,19 +99,19 @@ if "-setuptools" in sys.argv:
+ sys.argv.remove ("-setuptools")
+
+
+-# NOTE: the bdist_mpkg_support is for darwin.
+-try:
+- import bdist_mpkg_support
+- from setuptools import setup, Extension
+-except ImportError:
+- pass
+-else:
+- EXTRAS.update({
+- 'options': bdist_mpkg_support.options,
+- 'setup_requires': ['bdist_mpkg>=0.4.2'],
+- #'install_requires': ['pyobjc'],
+- #'dependency_links': ['http://rene.f0o.com/~rene/stuff/macosx/']
+- })
++# # NOTE: the bdist_mpkg_support is for darwin.
++# try:
++# import bdist_mpkg_support
++# from setuptools import setup, Extension
++# except ImportError:
++# pass
++# else:
++# EXTRAS.update({
++# 'options': bdist_mpkg_support.options,
++# 'setup_requires': ['bdist_mpkg>=0.4.2'],
++# #'install_requires': ['pyobjc'],
++# #'dependency_links': ['http://rene.f0o.com/~rene/stuff/macosx/']
++# })
+
+ #headers to install
+ headers = glob.glob(os.path.join('src', '*.h'))
+--
+2.1.2
+
diff --git a/dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild b/dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild
deleted file mode 100644
index c9d27d27a554..000000000000
--- a/dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild,v 1.7 2013/01/01 19:29:29 hasufell Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-**"
-PYTHON_TESTS_RESTRICTED_ABIS="3.1"
-PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
-
-inherit distutils virtualx
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="http://www.pygame.org/"
-if [[ "${PV}" == *_pre* ]]; then
- SRC_URI="http://people.apache.org/~Arfrever/gentoo/${P}.tar.xz"
-else
- SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc sparc x86 ~x86-fbsd"
-IUSE="doc examples X"
-
-DEPEND="dev-python/numpy
- >=media-libs/sdl-image-1.2.2[png,jpeg]
- >=media-libs/sdl-mixer-1.2.4
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/smpeg-0.4.4-r1
- X? ( >=media-libs/libsdl-1.2.5[X,video] )
- !X? ( >=media-libs/libsdl-1.2.5 )"
-RDEPEND="${DEPEND}"
-
-if [[ "${PV}" != *_pre* ]]; then
- S="${WORKDIR}/${P}release"
-fi
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="WHATSNEW"
-
-src_configure() {
- "$(PYTHON -f)" config.py -auto
-
- if ! use X; then
- sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
- fi
-
- # Disable automagic dependency on PortMidi.
- sed -e "s:^pypm :#&:" -i Setup || die "sed failed"
-
- sed -i -e "s/import _camera/from pygame &/g" lib/camera.py || die #415593
-}
-
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" run_tests.py
- }
- VIRTUALX_COMMAND="python_execute_function" virtualmake testing
-}
-
-src_install() {
- distutils_src_install
-
- delete_examples_and_tests() {
- rm -fr "${ED}$(python_get_sitedir)/pygame/examples"
- rm -fr "${ED}$(python_get_sitedir)/pygame/tests"
- }
- python_execute_function -q delete_examples_and_tests
-
- if use doc; then
- dohtml -r docs/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild b/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
index 0b2463f1e065..2a753443af5d 100644
--- a/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
+++ b/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild,v 1.11 2014/11/24 15:03:26 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre20120101-r2.ebuild,v 1.12 2015/02/28 18:06:08 pacho Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
@@ -33,6 +33,11 @@ if [[ "${PV}" != *_pre* ]]; then
S="${WORKDIR}/${P}release"
fi
+PATCHES=(
+ # Workaround bug #516434
+ "${FILESDIR}"/${P}-import-bdist.patch
+)
+
DOCS=( WHATSNEW )
python_configure() {