summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-04 23:04:09 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-04 23:04:09 +0000
commit4bc6cc8709d8e462a492870d3a252b36d0a1991e (patch)
treef42bb9d3cd8e320f6160dd9c6bd8eb87e9d85242 /dev-python/pygobject
parentInitial import (diff)
downloadgentoo-2-4bc6cc8709d8e462a492870d3a252b36d0a1991e.tar.gz
gentoo-2-4bc6cc8709d8e462a492870d3a252b36d0a1991e.tar.bz2
gentoo-2-4bc6cc8709d8e462a492870d3a252b36d0a1991e.zip
fix libffi condition, fix bug #230751
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'dev-python/pygobject')
-rw-r--r--dev-python/pygobject/ChangeLog6
-rw-r--r--dev-python/pygobject/files/pygobject-2.14.2-libffi.patch21
-rw-r--r--dev-python/pygobject/pygobject-2.14.2.ebuild10
3 files changed, 33 insertions, 4 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 4de52f3c5832..7c2a47a8298b 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.40 2008/05/29 16:26:20 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.41 2008/07/04 23:04:08 eva Exp $
+
+ 04 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/pygobject-2.14.2-libffi.patch, pygobject-2.14.2.ebuild:
+ fix libffi condition, fix bug #230751
29 May 2008; Ali Polatel <hawking@gentoo.org> pygobject-2.12.3.ebuild:
Use get_libdir.
diff --git a/dev-python/pygobject/files/pygobject-2.14.2-libffi.patch b/dev-python/pygobject/files/pygobject-2.14.2-libffi.patch
new file mode 100644
index 000000000000..c037e0616827
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-2.14.2-libffi.patch
@@ -0,0 +1,21 @@
+diff -ru pygobject-2.14.2.orig/configure.ac pygobject-2.14.2/configure.ac
+--- pygobject-2.14.2.orig/configure.ac 2008-05-23 12:51:11.000000000 -0400
++++ pygobject-2.14.2/configure.ac 2008-07-04 13:45:30.088664555 -0400
+@@ -146,7 +146,7 @@
+ dnl libffi
+ AC_MSG_CHECKING(for ffi.h)
+ AC_ARG_WITH(libffi,
+- AC_HELP_STRING([--without-ffi], [Disable libffi support]),
++ AC_HELP_STRING([--without-libffi], [Disable libffi support]),
+ with_ffi=$withval,
+ with_ffi=auto)
+ if test x"$with_ffi" = xno ; then
+@@ -170,7 +170,7 @@
+ LIBS=$save_LIBS
+ fi
+ fi
+-if test x"$with_ffi" != xauto && test x"$pygobject_ffi_h" != xyes ; then
++if test x"$with_ffi" == xyes && test x"$pygobject_ffi_h" != xyes ; then
+ AC_MSG_ERROR([libffi requested, but ffi.h not found])
+ fi
+ AC_MSG_RESULT([$pygobject_ffi_h])
diff --git a/dev-python/pygobject/pygobject-2.14.2.ebuild b/dev-python/pygobject/pygobject-2.14.2.ebuild
index 69093f40f4a8..1d85bb6bf46f 100644
--- a/dev-python/pygobject/pygobject-2.14.2.ebuild
+++ b/dev-python/pygobject/pygobject-2.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.2.ebuild,v 1.2 2008/05/29 14:23:41 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.14.2.ebuild,v 1.3 2008/07/04 23:04:08 eva Exp $
inherit gnome2 python autotools
@@ -29,17 +29,21 @@ pkg_setup() {
eerror "libffi support not found in sys-devel/gcc." && die
fi
- G2CONF="${G2CONF} $(use_enable doc docs) $(use_with libffi ffi)"
+ G2CONF="${G2CONF} $(use_enable doc docs) $(use_with libffi)"
}
src_unpack() {
gnome2_src_unpack
+ # fix libffi condition, fix bug #230751
+ epatch "${FILESDIR}/${P}-libffi.patch"
+
# fix bug #147285 - Robin H. Johnson <robbat2@gentoo.org>
# this is caused by upstream's automake-1.8 lacking some Gentoo-specific
# patches (for tmpfs amongst other things). Upstreams hit by this should
# move to newer automake versions ideally.
- AT_M4DIR="m4" eautomake
+ #AT_M4DIR="m4" eautomake
+ AT_M4DIR="m4" eautoreconf
# disable pyc compiling
mv py-compile py-compile.orig