summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 17:33:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 17:33:44 +0000
commit39d1fd8fd4c5ec9128b9a2a4bff2d99a7951d54f (patch)
tree185677cc98ebdc852f407b91c77871bbe01c8c0c /dev-python/pylint/pylint-0.20.0.ebuild
parentVersion bump (bug #311323). (diff)
downloadgentoo-2-39d1fd8fd4c5ec9128b9a2a4bff2d99a7951d54f.tar.gz
gentoo-2-39d1fd8fd4c5ec9128b9a2a4bff2d99a7951d54f.tar.bz2
gentoo-2-39d1fd8fd4c5ec9128b9a2a4bff2d99a7951d54f.zip
Version bump (bug #311323).
(Portage version: 15841-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pylint/pylint-0.20.0.ebuild')
-rw-r--r--dev-python/pylint/pylint-0.20.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pylint/pylint-0.20.0.ebuild b/dev-python/pylint/pylint-0.20.0.ebuild
new file mode 100644
index 000000000000..a1b5f8bc81fc
--- /dev/null
+++ b/dev-python/pylint/pylint-0.20.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.20.0.ebuild,v 1.1 2010/03/26 17:33:44 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+PYTHON_USE_WITH_OPT="tk"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="a tool to check if a Python module satisfies a coding standard"
+HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test tk"
+
+DEPEND=">=dev-python/logilab-common-0.44.0
+ >=dev-python/astng-0.19.3"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable failing tests.
+ rm -f test/input/func_arguments.py
+ sed -e "s/test_exhaustivity/_&/" -i test/test_func.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+ dodoc doc/FAQ.txt || die "dodoc failed"
+
+ if use doc; then
+ dodoc doc/*.txt || die "dodoc failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ if ! has_version dev-lang/python[tk]; then
+ ewarn "dev-lang/python has been built without tk support,"
+ ewarn "${PN}-gui doesn't work without Tkinter so if you really need it,"
+ ewarn "re-install dev-lang/python with \"tk\" useflag enabled."
+ fi
+}