summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2007-08-23 10:45:51 +0000
committerRobert Buchholz <rbu@gentoo.org>2007-08-23 10:45:51 +0000
commit42e150d138edc46550cd31f0270cdcc12619805b (patch)
treec90db0bf9c528bfd7151076b8371369baf3e1092 /dev-python/pynotifier/pynotifier-0.5.8-r1.ebuild
parent Redo the Makefile patch so it doesn't specify install user/group and it (diff)
downloadgentoo-2-42e150d138edc46550cd31f0270cdcc12619805b.tar.gz
gentoo-2-42e150d138edc46550cd31f0270cdcc12619805b.tar.bz2
gentoo-2-42e150d138edc46550cd31f0270cdcc12619805b.zip
Making qt and gtk optional dependancies
(Portage version: 2.1.3.6)
Diffstat (limited to 'dev-python/pynotifier/pynotifier-0.5.8-r1.ebuild')
-rw-r--r--dev-python/pynotifier/pynotifier-0.5.8-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pynotifier/pynotifier-0.5.8-r1.ebuild b/dev-python/pynotifier/pynotifier-0.5.8-r1.ebuild
new file mode 100644
index 000000000000..92efe1a595d5
--- /dev/null
+++ b/dev-python/pynotifier/pynotifier-0.5.8-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pynotifier/pynotifier-0.5.8-r1.ebuild,v 1.1 2007/08/23 10:45:51 rbu Exp $
+
+inherit distutils
+
+DESCRIPTION="pyNotifier provides an implementation of a notifier/event scheduler."
+HOMEPAGE="http://www.bitkipper.net/Package/pynotifier"
+SRC_URI="http://www.bitkipper.net/bytes/pynotifier/source/${PN}_${PV}-1.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="qt4 gtk"
+
+DEPEND=""
+RDEPEND="gtk? ( dev-python/pygobject )
+ qt4? ( dev-python/PyQt4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use qt4 || rm notifier/nf_qt.py
+ use gtk || rm notifier/nf_gtk.py
+
+ # This would need dev-python/wxpython
+ # pynotifier's source: "the WX notifier is deprecated and is no longer maintained"
+ rm notifier/nf_wx.py
+}