summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-25 07:15:11 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-25 07:15:11 +0000
commite150bb6334eb2cf5ad30ed7be749a7be1d13f18f (patch)
treeb060312cb4d7e6810d56dfedc3791b794b0e3043 /dev-python/pyopenssl
parentFix ability to compile with USE=-ruby for bug #497080. (diff)
downloadgentoo-2-e150bb6334eb2cf5ad30ed7be749a7be1d13f18f.tar.gz
gentoo-2-e150bb6334eb2cf5ad30ed7be749a7be1d13f18f.tar.bz2
gentoo-2-e150bb6334eb2cf5ad30ed7be749a7be1d13f18f.zip
skip broken tests, fix matches findings of Arfrever, upstream notifies, fixes Bug #501636 by E. Maschino, update doc install
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/ChangeLog8
-rw-r--r--dev-python/pyopenssl/pyopenssl-0.14-r1.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/pyopenssl/ChangeLog b/dev-python/pyopenssl/ChangeLog
index e54c906de201..d513b9972e57 100644
--- a/dev-python/pyopenssl/ChangeLog
+++ b/dev-python/pyopenssl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyopenssl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopenssl/ChangeLog,v 1.118 2014/03/22 23:09:12 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopenssl/ChangeLog,v 1.119 2014/03/25 07:15:11 idella4 Exp $
+
+*pyopenssl-0.14-r1 (25 Mar 2014)
+
+ 25 Mar 2014; Ian Delaney <idella4@gentoo.org> +pyopenssl-0.14-r1.ebuild:
+ skip broken tests, fix matches findings of Arfrever, upstream notifies, fixes
+ Bug #501636 by E. Maschino, update doc install
22 Mar 2014; Markos Chandras <hwoarang@gentoo.org> pyopenssl-0.14.ebuild:
Add ~mips. Bug #503094
diff --git a/dev-python/pyopenssl/pyopenssl-0.14-r1.ebuild b/dev-python/pyopenssl/pyopenssl-0.14-r1.ebuild
new file mode 100644
index 000000000000..f1713927472c
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-0.14-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopenssl/pyopenssl-0.14-r1.ebuild,v 1.1 2014/03/25 07:15:11 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="http://pyopenssl.sourceforge.net/ https://launchpad.net/pyopenssl http://pypi.python.org/pypi/pyOpenSSL"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed \
+ -e "s/test_set_tlsext_host_name_wrong_args/_&/" \
+ -i OpenSSL/test/test_ssl.py || die "test_ssl sed failed"
+
+ # https://github.com/pyca/pyopenssl/issues/41
+ sed -e "s/test_digest/_&/" -i OpenSSL/test/test_crypto.py
+ # https://github.com/pyca/pyopenssl/issues/67
+ sed -e "s/test_wantWriteError/_&/" -i OpenSSL/test/test_ssl.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+
+ # https://bugs.launchpad.net/pyopenssl/+bug/1237953
+ rm -rf tmp* *.key *.pem
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}