summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-04 07:02:46 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-04 07:02:46 +0000
commit20950a317653cf51e48ff5a304adf069c7dc755b (patch)
treeb0b724dd3c7895e87f0f5e862174a18cf503968f /dev-python/pyosd
parentdigest (diff)
downloadgentoo-2-20950a317653cf51e48ff5a304adf069c7dc755b.tar.gz
gentoo-2-20950a317653cf51e48ff5a304adf069c7dc755b.tar.bz2
gentoo-2-20950a317653cf51e48ff5a304adf069c7dc755b.zip
revbump; conversion -> distutils-r1
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyosd')
-rw-r--r--dev-python/pyosd/ChangeLog9
-rw-r--r--dev-python/pyosd/pyosd-0.2.14-r1.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-python/pyosd/ChangeLog b/dev-python/pyosd/ChangeLog
index 593341f31314..0a1b7b7b8f2e 100644
--- a/dev-python/pyosd/ChangeLog
+++ b/dev-python/pyosd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyosd
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyosd/ChangeLog,v 1.24 2014/08/10 21:17:26 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyosd/ChangeLog,v 1.25 2015/01/04 07:02:46 idella4 Exp $
+
+*pyosd-0.2.14-r1 (04 Jan 2015)
+
+ 04 Jan 2015; Ian Delaney <idella4@gentoo.org> +pyosd-0.2.14-r1.ebuild:
+ revbump; conversion -> distutils-r1
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> pyosd-0.2.14.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/dev-python/pyosd/pyosd-0.2.14-r1.ebuild b/dev-python/pyosd/pyosd-0.2.14-r1.ebuild
new file mode 100644
index 000000000000..68c9f8ce9458
--- /dev/null
+++ b/dev-python/pyosd/pyosd-0.2.14-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyosd/pyosd-0.2.14-r1.ebuild,v 1.1 2015/01/04 07:02:46 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for displaying text on your X display, like the 'On Screen Displays' used on TVs"
+HOMEPAGE="http://ichi2.net/pyosd/"
+SRC_URI="http://ichi2.net/pyosd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc examples"
+
+DEPEND=">=x11-libs/xosd-2.2.4"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( pyosd.html )
+ use examples && local EXAMPLES=( modules/. )
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "If you want to run the included daemon, you will need to install dev-python/twisted-core."
+ elog "Also note that the volume plugin requires media-sound/aumix."
+}