summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-13 16:01:56 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-13 16:01:56 +0000
commit85c56f358651a72ffbb5987695c706543211ad3e (patch)
treed9e886513e02e675eb5e6ca1998f3a01acad5831 /dev-python/pyparted
parentRemove forced mount-locking for live ebuild. (diff)
downloadgentoo-2-85c56f358651a72ffbb5987695c706543211ad3e.tar.gz
gentoo-2-85c56f358651a72ffbb5987695c706543211ad3e.tar.bz2
gentoo-2-85c56f358651a72ffbb5987695c706543211ad3e.zip
Version bump. Migrate to distutils-r1.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog10
-rw-r--r--dev-python/pyparted/pyparted-3.10.ebuild32
2 files changed, 39 insertions, 3 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index b7bec702a75c..a3d5d6257cf8 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparted
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.74 2012/12/31 18:00:19 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.75 2013/06/13 16:01:56 jer Exp $
+
+*pyparted-3.10 (13 Jun 2013)
+
+ 13 Jun 2013; Jeroen Roovers <jer@gentoo.org> +pyparted-3.10.ebuild:
+ Version bump. Migrate to distutils-r1.
*pyparted-3.9 (31 Dec 2012)
@@ -280,4 +285,3 @@
23 Apr 2004; Nathaniel McCallum <npmccallum@gentoo.org> :
new ebuild
-
diff --git a/dev-python/pyparted/pyparted-3.10.ebuild b/dev-python/pyparted/pyparted-3.10.ebuild
new file mode 100644
index 000000000000..6140cc7da893
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.10.ebuild,v 1.1 2013/06/13 16:01:56 jer Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_1,3_2} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+"
+# test? ( dev-python/pychecker )
+
+src_test() {
+ ewarn "Test suite disabled until dev-python/pychecker"
+ ewarn "is migrated to -r1.eclass"
+}