summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathaniel McCallum <npmccallum@gentoo.org>2004-04-23 05:44:32 +0000
committerNathaniel McCallum <npmccallum@gentoo.org>2004-04-23 05:44:32 +0000
commitd0bedc6aa519baa292b39c2b378e200371f70921 (patch)
tree756cb0db84dde49dca9fdfc02dc3739b05caa343 /dev-python/pyparted
parent (Manifest recommit) (diff)
downloadgentoo-2-d0bedc6aa519baa292b39c2b378e200371f70921.tar.gz
gentoo-2-d0bedc6aa519baa292b39c2b378e200371f70921.tar.bz2
gentoo-2-d0bedc6aa519baa292b39c2b378e200371f70921.zip
new ebuild for pyparted
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog7
-rw-r--r--dev-python/pyparted/Manifest2
-rw-r--r--dev-python/pyparted/files/digest-pyparted-1.6.61
-rw-r--r--dev-python/pyparted/metadata.xml5
-rw-r--r--dev-python/pyparted/pyparted-1.6.6.ebuild41
5 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
new file mode 100644
index 000000000000..c58af9df50fc
--- /dev/null
+++ b/dev-python/pyparted/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-python/pyparted
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.1 2004/04/23 05:44:32 npmccallum Exp $
+
+ 23 Apr 2004; Nathaniel McCallum <npmccallum@gentoo.org> :
+ new ebuild
+
diff --git a/dev-python/pyparted/Manifest b/dev-python/pyparted/Manifest
new file mode 100644
index 000000000000..0ce910043f71
--- /dev/null
+++ b/dev-python/pyparted/Manifest
@@ -0,0 +1,2 @@
+MD5 bfa26491aa4eb0d3704ec66d612fa47a pyparted-1.6.6.ebuild 685
+MD5 1c3b5c95a85ac9c079423549c7922a84 files/digest-pyparted-1.6.6 69
diff --git a/dev-python/pyparted/files/digest-pyparted-1.6.6 b/dev-python/pyparted/files/digest-pyparted-1.6.6
new file mode 100644
index 000000000000..0f02c903716f
--- /dev/null
+++ b/dev-python/pyparted/files/digest-pyparted-1.6.6
@@ -0,0 +1 @@
+MD5 451090e61cf2e69f4cef0c32f0fbdbee pyparted-1.6.6-2.src.rpm 296457
diff --git a/dev-python/pyparted/metadata.xml b/dev-python/pyparted/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/pyparted/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pyparted/pyparted-1.6.6.ebuild b/dev-python/pyparted/pyparted-1.6.6.ebuild
new file mode 100644
index 000000000000..095573c08720
--- /dev/null
+++ b/dev-python/pyparted/pyparted-1.6.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.6.6.ebuild,v 1.1 2004/04/23 05:44:32 npmccallum Exp $
+
+RH_EXTRAVERSION="2"
+
+DESCRIPTION="Python bindings for parted"
+HOMEPAGE="http://fedora.redhat.com"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/${P}-${RH_EXTRAVERSION}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE=""
+
+# Needed to build...
+DEPEND=">=sys-apps/parted-1.6.9"
+
+RDEPEND="${DEPEND}"
+
+inherit eutils rpm
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_compile() {
+ cd ${S}
+
+ # This is needed otherwise it won't build
+ # If anyone wants to figure out why... go ahead!
+ export LDFLAGS="-ldl"
+ econf || die
+ emake || die
+}
+
+src_install () {
+ einstall || die "Install failed!"
+ dodoc AUTHORS COPYING README ChangeLog
+}