summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-11-07 15:18:56 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-11-07 15:18:56 +0000
commitad8d4ff2d7c6256d62a06f1b3364ff0ff001a9b1 (patch)
treec8d31c57c23026c8729545c2e2900f2828547a9a /dev-python/pypax
parentFixed problems with init script. Removed some older ebuilds (diff)
downloadgentoo-2-ad8d4ff2d7c6256d62a06f1b3364ff0ff001a9b1.tar.gz
gentoo-2-ad8d4ff2d7c6256d62a06f1b3364ff0ff001a9b1.tar.bz2
gentoo-2-ad8d4ff2d7c6256d62a06f1b3364ff0ff001a9b1.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-python/pypax')
-rw-r--r--dev-python/pypax/ChangeLog7
-rw-r--r--dev-python/pypax/pypax-0.8.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/pypax/ChangeLog b/dev-python/pypax/ChangeLog
index 47ef8c6c230a..f6e216e0b5dd 100644
--- a/dev-python/pypax/ChangeLog
+++ b/dev-python/pypax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pypax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/ChangeLog,v 1.73 2013/09/05 18:46:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/ChangeLog,v 1.74 2013/11/07 15:18:56 blueness Exp $
+
+*pypax-0.8.4 (07 Nov 2013)
+
+ 07 Nov 2013; Anthony G. Basile <blueness@gentoo.org> +pypax-0.8.4.ebuild:
+ Version bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> pypax-0.8.1-r1.ebuild,
pypax-0.8.3.ebuild:
diff --git a/dev-python/pypax/pypax-0.8.4.ebuild b/dev-python/pypax/pypax-0.8.4.ebuild
new file mode 100644
index 000000000000..568a3a624972
--- /dev/null
+++ b/dev-python/pypax/pypax-0.8.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypax/pypax-0.8.4.ebuild,v 1.1 2013/11/07 15:18:56 blueness Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to get or set either PT_PAX and/or XATTR_PAX flags"
+HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/
+ http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/elfix-${PV}.tar.gz"
+
+S="${WORKDIR}/elfix-${PV}/scripts"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND=""
+
+src_compile() {
+ unset PTPAX
+ unset XTPAX
+ use ptpax && export PTPAX="yes"
+ use xtpax && export XTPAX="yes"
+}