summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-03-13 19:17:30 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-03-13 19:17:30 +0000
commit9f1d238e8df7b3efd1794e7441ac1afbf128fa96 (patch)
treef595dbab0455875c4a88d54ae2f0a8e569e2efd2 /dev-python/pyqwt/pyqwt-4.2-r1.ebuild
parentversion bump; clean out old version (diff)
downloadgentoo-2-9f1d238e8df7b3efd1794e7441ac1afbf128fa96.tar.gz
gentoo-2-9f1d238e8df7b3efd1794e7441ac1afbf128fa96.tar.bz2
gentoo-2-9f1d238e8df7b3efd1794e7441ac1afbf128fa96.zip
Python 2.5 fix. bug# 158510
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-python/pyqwt/pyqwt-4.2-r1.ebuild')
-rw-r--r--dev-python/pyqwt/pyqwt-4.2-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyqwt/pyqwt-4.2-r1.ebuild b/dev-python/pyqwt/pyqwt-4.2-r1.ebuild
new file mode 100644
index 000000000000..a15dc804ba24
--- /dev/null
+++ b/dev-python/pyqwt/pyqwt-4.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-4.2-r1.ebuild,v 1.1 2007/03/13 19:17:30 pythonhead Exp $
+
+
+inherit distutils eutils
+
+MY_P=PyQwt-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Python bindings for the Qwt library"
+SRC_URI="mirror://sourceforge/pyqwt/${MY_P}.tar.gz"
+HOMEPAGE="http://pyqwt.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="debug"
+
+DEPEND=">=dev-lang/python-2.3.2
+ ~x11-libs/qwt-4.2.0
+ >=dev-python/PyQt-3.14
+ >=dev-python/sip-4.2
+ >=dev-python/numarray-1.1.1
+ >=dev-python/numeric-23.7"
+
+src_compile() {
+ cd ${S}/sip
+ sed -i s/"[[:space:]]*const QLabel \*titleLabel() const\;"// qwtplot.sip
+ sed -i s/"[[:space:]]*const QwtPlotCanvas \*canvas() const\;"// qwtplot.sip
+ cd ${S}/configure
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -l /usr/$(get_libdir) \
+ -i /usr/include/qwt -v /usr/share/sip -x /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+ has distcc ${FEATURES} || myconf="${myconf} -c"
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}
+ sed -i s/2,4,9/2,5,9/ setup.py
+ python setup.py install --prefix=/usr --root=${D} || die "install failed"
+ dodoc ANNOUNCEMENT-4.2.TXT AUTHORS COPYING* README THANKS
+ use doc && mv ${D}/usr/share/doc/${MY_P}/* ${D}/usr/share/doc/${PF}
+ rm -rf ${D}/usr/share/doc/${MY_P}
+}