summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-11-17 04:20:42 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-11-17 04:20:42 +0000
commite24caa8124478dc40e89be4845056227efadd3f1 (patch)
tree15a0c474423a4c2f7cca702fbacacbf4a7b89cf4 /dev-python/pyrax
parentadded pytest-2.4.2 with restricted tests due to upstream bug (diff)
downloadgentoo-2-e24caa8124478dc40e89be4845056227efadd3f1.tar.gz
gentoo-2-e24caa8124478dc40e89be4845056227efadd3f1.tar.bz2
gentoo-2-e24caa8124478dc40e89be4845056227efadd3f1.zip
1.6.1 with restricted tests due to upstream bug
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/pyrax')
-rw-r--r--dev-python/pyrax/ChangeLog5
-rw-r--r--dev-python/pyrax/pyrax-1.6.1.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-python/pyrax/ChangeLog b/dev-python/pyrax/ChangeLog
index 81f85f39593e..ba9662cb23e0 100644
--- a/dev-python/pyrax/ChangeLog
+++ b/dev-python/pyrax/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyrax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v 1.10 2013/11/09 05:52:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/ChangeLog,v 1.11 2013/11/17 04:20:42 prometheanfire Exp $
+
+ 17 Nov 2013; Matthew Thode <prometheanfire@gentoo.org> pyrax-1.6.1.ebuild:
+ 1.6.1 with restricted tests due to upstream bug
*pyrax-1.6.1 (09 Nov 2013)
diff --git a/dev-python/pyrax/pyrax-1.6.1.ebuild b/dev-python/pyrax/pyrax-1.6.1.ebuild
index bd892c35f6c1..9f5727977f89 100644
--- a/dev-python/pyrax/pyrax-1.6.1.ebuild
+++ b/dev-python/pyrax/pyrax-1.6.1.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/pyrax-1.6.1.ebuild,v 1.1 2013/11/09 05:52:06 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyrax/pyrax-1.6.1.ebuild,v 1.2 2013/11/17 04:20:42 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
+RESTRICT="test"
+#due to https://github.com/rackspace/pyrax/issues/245
+
inherit distutils-r1
DESCRIPTION="Python SDK for OpenStack/Rackspace APIs"
@@ -30,8 +33,8 @@ RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]
>=dev-python/python-swiftclient-1.5.0[${PYTHON_USEDEP}]
dev-python/rackspace-novaclient[${PYTHON_USEDEP}]"
-#python_test() {
-#disabling due to failures https://github.com/rackspace/pyrax/issues/245
-# "${PYTHON}" -m nose -v tests/unit --with-cover --cover-package=pyrax || die
+python_test() {
+ "${PYTHON}" -m nose -v tests/unit --with-cover --cover-package=pyrax || die
# "${PYTHON}" -m nose -w tests/unit || die
-#}
+# nosetests --with-coverage --cover-package=pyrax --cover-erase -w tests/unit/ || die
+}