summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-08 23:10:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-08 23:10:55 +0000
commitc5c58528474e240e7e2d2e0078be5950a6849104 (patch)
treee7c746cec15570aa755cad354680d40e387aa4be /dev-python/pyro
parentStable on amd64 wrt bug #357659 (diff)
downloadgentoo-2-c5c58528474e240e7e2d2e0078be5950a6849104.tar.gz
gentoo-2-c5c58528474e240e7e2d2e0078be5950a6849104.tar.bz2
gentoo-2-c5c58528474e240e7e2d2e0078be5950a6849104.zip
Version bumps.
(Portage version: 2.2.0_alpha26_p8/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog9
-rw-r--r--dev-python/pyro/pyro-3.12.ebuild41
-rw-r--r--dev-python/pyro/pyro-4.3.ebuild75
3 files changed, 124 insertions, 1 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index 92af34a7ff2f..cada53212771 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.30 2011/01/07 15:58:09 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.31 2011/03/08 23:10:55 arfrever Exp $
+
+*pyro-4.3 (08 Mar 2011)
+*pyro-3.12 (08 Mar 2011)
+
+ 08 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyro-3.12.ebuild, +pyro-4.3.ebuild:
+ Version bumps.
07 Jan 2011; Brent Baude <ranger@gentoo.org> pyro-4.1.ebuild:
Marking pyro-4.1 ppc for bug 347107
diff --git a/dev-python/pyro/pyro-3.12.ebuild b/dev-python/pyro/pyro-3.12.ebuild
new file mode 100644
index 000000000000..0ea7f8c57804
--- /dev/null
+++ b/dev-python/pyro/pyro-3.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.12.ebuild,v 1.1 2011/03/08 23:10:55 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_P="Pyro-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro3/ http://pypi.python.org/pypi/Pyro"
+SRC_URI="http://www.xs4all.nl/~irmen/pyro3/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+DEPEND="!dev-python/pyro:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Pyro"
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}
diff --git a/dev-python/pyro/pyro-4.3.ebuild b/dev-python/pyro/pyro-4.3.ebuild
new file mode 100644
index 000000000000..4491715d4094
--- /dev/null
+++ b/dev-python/pyro/pyro-4.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.3.ebuild,v 1.1 2011/03/08 23:10:55 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+
+inherit distutils
+
+MY_P="Pyro4-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro4/ http://www.razorvine.net/python/Pyro http://pypi.python.org/pypi/Pyro4"
+SRC_URI="http://www.xs4all.nl/~irmen/pyro4/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+DEPEND="!dev-python/pyro:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Pyro4"
+
+src_prepare() {
+ distutils_src_prepare
+
+ find -name "._*" -print0 | xargs -0 rm -f
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/testOwnloopBasics/_&/" \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/namingtests2.py
+ sed -e "s/testServerConnections/_&/" -i tests/PyroTests/servertests.py
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -i tests/PyroTests/sockettests.py
+ sed \
+ -e "s/testBCstart/_&/" \
+ -e "s/testDaemonPyroObj/_&/" \
+ -e "s/testLookupAndRegister/_&/" \
+ -e "s/testMulti/_&/" \
+ -e "s/testRefuseDottedNames/_&/" \
+ -e "s/testResolve/_&/" \
+ -i tests/PyroTests/namingtests.py
+}
+
+src_test() {
+ cd tests
+
+ testing() {
+ "$(PYTHON)" run_testsuite.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}