summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-12 16:56:52 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-12 16:56:52 +0000
commita3dd76d4700e7d6ae4ecf962490868bdd154281a (patch)
treef6dad5360562ae6420dc9ab8a966d3ca4dd4a07e /dev-python/pysvn
parentBlock drivers that don't build against xorg-server-1.14 (diff)
downloadgentoo-2-a3dd76d4700e7d6ae4ecf962490868bdd154281a.tar.gz
gentoo-2-a3dd76d4700e7d6ae4ecf962490868bdd154281a.tar.bz2
gentoo-2-a3dd76d4700e7d6ae4ecf962490868bdd154281a.zip
bump, some test scripts fial, test restrited
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog9
-rw-r--r--dev-python/pysvn/files/pysvn-1.7.7-respect_flags.patch95
-rw-r--r--dev-python/pysvn/pysvn-1.7.7.ebuild70
3 files changed, 173 insertions, 1 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index 27708c940e2b..e425e75e77e3 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pysvn
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.31 2013/01/13 11:40:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.32 2013/03/12 16:56:52 idella4 Exp $
+
+*pysvn-1.7.7 (12 Mar 2013)
+
+ 12 Mar 2013; Ian Delaney <idella4@gentoo.org>
+ +files/pysvn-1.7.7-respect_flags.patch, +pysvn-1.7.7.ebuild,
+ files/pysvn-1.7.6-respect_flags.patch, pysvn-1.7.6.ebuild:
+ bump, some test scripts fial, test restrited
13 Jan 2013; Agostino Sarubbo <ago@gentoo.org> pysvn-1.7.6.ebuild:
Stable for x86, wrt bug #449782
diff --git a/dev-python/pysvn/files/pysvn-1.7.7-respect_flags.patch b/dev-python/pysvn/files/pysvn-1.7.7-respect_flags.patch
new file mode 100644
index 000000000000..e36171baeda3
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.7.7-respect_flags.patch
@@ -0,0 +1,95 @@
+--- Source/setup_configure.py
++++ Source/setup_configure.py
+@@ -830,8 +830,8 @@
+ def __init__( self, setup ):
+ Compiler.__init__( self, setup )
+
+- self._addVar( 'CCC', 'g++' )
+- self._addVar( 'CC', 'gcc' )
++ self._addVar( 'CCC', '$(CXX)' )
++ self._addVar( 'CC', '$(CC)' )
+
+ def getPythonExtensionFileExt( self ):
+ return '.so'
+@@ -948,8 +948,8 @@
+ else:
+ arch_options = ''
+
+- self._addVar( 'CCC', 'g++ %s' % (arch_options,) )
+- self._addVar( 'CC', 'gcc %s' % (arch_options,) )
++ self._addVar( 'CCC', '$(CXX) %s' % (arch_options,) )
++ self._addVar( 'CC', '$(CC) %s' % (arch_options,) )
+
+ self._find_paths_pycxx_dir = [
+ '../Import/pycxx-%d.%d.%d' % pycxx_version,
+@@ -1014,12 +1014,12 @@
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-no-long-double '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1031,7 +1031,7 @@
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
+- '-g',
++ '$(CXXFLAGS)',
+ '-no-long-double',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(SVN_INC)s',
+@@ -1058,13 +1058,12 @@
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( py_ld_libs ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -bundle '
+ '-framework System '
+ '%(PYTHON_FRAMEWORK)s '
+ '-framework CoreFoundation '
+ '-framework Kerberos '
+- '-framework Security '
+- '%(LDLIBS)s' )
++ '-framework Security' )
+
+ class UnixCompilerGCC(CompilerGCC):
+ def __init__( self, setup ):
+@@ -1124,11 +1123,11 @@
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
++ '$(CXXFLAGS) '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '$(CXX) $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1138,6 +1137,7 @@
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
++ '$(CXXFLAGS)',
+ '-Wall -fPIC -fexceptions -frtti',
+ '-I. -I%(APR_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1154,7 +1154,7 @@
+
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -shared -g' )
++ self._addVar( 'LDSHARED', '$(CXX) $(LDFLAGS) -shared' )
+
+ #--------------------------------------------------------------------------------
+ class LinuxCompilerGCC(UnixCompilerGCC):
diff --git a/dev-python/pysvn/pysvn-1.7.7.ebuild b/dev-python/pysvn/pysvn-1.7.7.ebuild
new file mode 100644
index 000000000000..cd832fc12bd8
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.7.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.7.ebuild,v 1.1 2013/03/12 16:56:52 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+
+inherit eutils distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-6.2.0
+ <dev-vcs/subversion-1.8" # (bug #395533)
+RDEPEND="${DEPEND}"
+# Currently fail, no facility to add new issue upstream
+RESTRICT="test"
+
+python_prepare() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -fr Import
+
+ epatch "${FILESDIR}"/${PN}-1.7.7-respect_flags.patch
+
+ # http://pysvn.tigris.org/source/browse/pysvn?view=rev&revision=1469
+ sed -e "s/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_16/PYSVN_HAS_SVN_CLIENT_CTX_T__CONFLICT_FUNC_1_6/" -i Source/pysvn_svnenv.hpp
+
+ pushd Source > /dev/null
+ if [[ "${EPYTHON:6:3}" == "2.5" ]]; then
+ "${PYTHON}" setup.py backport || die "Backport failed"
+ fi
+}
+
+python_configure() {
+ cd Source
+ # all config options from 1.7.6 are all already set
+ "${PYTHON}" setup.py configure
+}
+
+python_compile() {
+ cd Source
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+python_test() {
+ cd Tests
+ LC_ALL="en_US.UTF-8" emake
+}
+
+python_install() {
+ cd Source/pysvn
+ exeinto "$(python_get_sitedir)"/pysvn
+ doexe _pysvn*$(get_modname)
+ insinto "$(python_get_sitedir)"/pysvn
+ doins __init__.py
+
+ use doc && dohtml -r Docs/
+
+ if use examples; then
+ docinto examples
+ dodoc Examples/Client/*
+ fi
+}