summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-12-23 10:04:45 +0000
committerTim Harder <radhermit@gentoo.org>2012-12-23 10:04:45 +0000
commit3f9f77ef3ba78e4cdaca640d8b344023c4175834 (patch)
tree4e347aed8d212b1ae7a1efeed1dc8da38efe0a3d /dev-python/pytest
parentVersion bump. Migrate to distutils-r1. (diff)
downloadgentoo-2-3f9f77ef3ba78e4cdaca640d8b344023c4175834.tar.gz
gentoo-2-3f9f77ef3ba78e4cdaca640d8b344023c4175834.tar.bz2
gentoo-2-3f9f77ef3ba78e4cdaca640d8b344023c4175834.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog7
-rw-r--r--dev-python/pytest/pytest-2.3.4.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 5f74e53d152a..79d45fbc187b 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.43 2012/12/17 20:02:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.44 2012/12/23 10:04:45 radhermit Exp $
+
+*pytest-2.3.4 (23 Dec 2012)
+
+ 23 Dec 2012; Tim Harder <radhermit@gentoo.org> +pytest-2.3.4.ebuild:
+ Version bump.
17 Dec 2012; Michał Górny <mgorny@gentoo.org> pytest-2.3.3-r1.ebuild:
Bump to EAPI=5 to make Paludis happy, bug #447524.
diff --git a/dev-python/pytest/pytest-2.3.4.ebuild b/dev-python/pytest/pytest-2.3.4.ebuild
new file mode 100644
index 000000000000..914db748eebc
--- /dev/null
+++ b/dev-python/pytest/pytest-2.3.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.1 2012/12/23 10:04:45 radhermit Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+inherit distutils-r1
+
+DESCRIPTION="py.test: simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.4.12"
+RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGELOG README.txt )
+
+python_prepare_all() {
+ # Disable versioning of py.test script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ mkdir doc/en/.build || die
+ emake -C doc/en html
+ fi
+}
+
+python_test() {
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && dohtml -r doc/en/_build/html/
+}