summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-28 07:12:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-28 07:12:18 +0000
commit504df0149ec6d7ab0acd4544d68c8fbc0bbf448e (patch)
tree624f8e2e31451f11748f2ece03a70f1beb024bd8 /dev-python/pytest
parentBump (diff)
downloadgentoo-2-504df0149ec6d7ab0acd4544d68c8fbc0bbf448e.tar.gz
gentoo-2-504df0149ec6d7ab0acd4544d68c8fbc0bbf448e.tar.bz2
gentoo-2-504df0149ec6d7ab0acd4544d68c8fbc0bbf448e.zip
Bump
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog8
-rw-r--r--dev-python/pytest/pytest-2.2.4.ebuild47
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 9f160529003c..744f9dfb5f7e 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.36 2012/05/12 20:13:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.37 2012/06/28 07:12:18 patrick Exp $
+
+*pytest-2.2.4 (28 Jun 2012)
+
+ 28 Jun 2012; Patrick Lauer <patrick@gentoo.org> +pytest-2.2.4.ebuild:
+ Bump
12 May 2012; Alexis Ballier <aballier@gentoo.org> pytest-2.2.3.ebuild:
keyword ~amd64-fbsd
@@ -134,4 +139,3 @@
13 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+pytest-2.0.0.ebuild, +metadata.xml:
Initial addition. Ebuild written by me.
-
diff --git a/dev-python/pytest/pytest-2.2.4.ebuild b/dev-python/pytest/pytest-2.2.4.ebuild
new file mode 100644
index 000000000000..4d0ece3483de
--- /dev/null
+++ b/dev-python/pytest/pytest-2.2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.2.4.ebuild,v 1.1 2012/06/28 07:12:18 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="py.test: simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/py-1.4.7"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+DOCS="CHANGELOG README.txt"
+PYTHON_MODNAME="pytest.py _pytest"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
+
+ # Bug 380275: Test suite pre-compiles modules
+ python_clean_installation_image -q
+}