summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-30 08:05:44 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-30 08:05:44 +0000
commitc5b05a939187d2a0786de7e0c5b46a7bfad8b694 (patch)
treef2684f1b7f5c34894326b99d5f3faf1dd773b9db /dev-python/pytest
parentBump (diff)
downloadgentoo-2-c5b05a939187d2a0786de7e0c5b46a7bfad8b694.tar.gz
gentoo-2-c5b05a939187d2a0786de7e0c5b46a7bfad8b694.tar.bz2
gentoo-2-c5b05a939187d2a0786de7e0c5b46a7bfad8b694.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog7
-rw-r--r--dev-python/pytest/pytest-2.3.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 744f9dfb5f7e..c60bc2a9a3be 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.37 2012/06/28 07:12:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.38 2012/10/30 08:05:44 patrick Exp $
+
+*pytest-2.3.2 (30 Oct 2012)
+
+ 30 Oct 2012; Patrick Lauer <patrick@gentoo.org> +pytest-2.3.2.ebuild:
+ Bump
*pytest-2.2.4 (28 Jun 2012)
diff --git a/dev-python/pytest/pytest-2.3.2.ebuild b/dev-python/pytest/pytest-2.3.2.ebuild
new file mode 100644
index 000000000000..63766768f3ea
--- /dev/null
+++ b/dev-python/pytest/pytest-2.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.2.ebuild,v 1.1 2012/10/30 08:05:44 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="py.test: simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/py-1.4.7"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+DOCS="CHANGELOG README.txt"
+PYTHON_MODNAME="pytest.py _pytest"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" "build-${PYTHON_ABI}/lib/pytest.py"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
+
+ # Bug 380275: Test suite pre-compiles modules
+ python_clean_installation_image -q
+}