summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-07-19 18:59:11 +0000
committerMike Gilbert <floppym@gentoo.org>2014-07-19 18:59:11 +0000
commitd02f81224a6ce08623d9d8ae0ff39d34a2c81d2c (patch)
treee15e94c18e37172876be6dffacf071290bbd3607 /dev-python/pytest
parentStable on alpha, bug #397225 (diff)
downloadgentoo-2-d02f81224a6ce08623d9d8ae0ff39d34a2c81d2c.tar.gz
gentoo-2-d02f81224a6ce08623d9d8ae0ff39d34a2c81d2c.tar.bz2
gentoo-2-d02f81224a6ce08623d9d8ae0ff39d34a2c81d2c.zip
Use python_gen_cond_dep.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog6
-rw-r--r--dev-python/pytest/pytest-2.4.2.ebuild4
-rw-r--r--dev-python/pytest/pytest-2.5.2.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 00bdf2492a84..1cf86bdf9a40 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.90 2014/07/06 12:49:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.91 2014/07/19 18:59:11 floppym Exp $
+
+ 19 Jul 2014; Mike Gilbert <floppym@gentoo.org> pytest-2.4.2.ebuild,
+ pytest-2.5.2.ebuild:
+ Use python_gen_cond_dep.
06 Jul 2014; Michał Górny <mgorny@gentoo.org> pytest-2.4.2.ebuild,
pytest-2.5.2.ebuild:
diff --git a/dev-python/pytest/pytest-2.4.2.ebuild b/dev-python/pytest/pytest-2.4.2.ebuild
index 8468dd8f9960..10dd81d73268 100644
--- a/dev-python/pytest/pytest-2.4.2.ebuild
+++ b/dev-python/pytest/pytest-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.10 2014/07/06 12:49:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.11 2014/07/19 18:59:11 floppym Exp $
EAPI="5"
@@ -24,7 +24,7 @@ RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/pexpect[$(python_gen_usedep python{2_6,2_7,3_2,3_3})]
+ $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 'python*')
dev-python/pyyaml[${PYTHON_USEDEP}]
)
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
diff --git a/dev-python/pytest/pytest-2.5.2.ebuild b/dev-python/pytest/pytest-2.5.2.ebuild
index a6b1f9c465df..b731bf76c695 100644
--- a/dev-python/pytest/pytest-2.5.2.ebuild
+++ b/dev-python/pytest/pytest-2.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.5 2014/07/06 12:49:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.6 2014/07/19 18:59:11 floppym Exp $
EAPI="5"
@@ -24,7 +24,7 @@ RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- dev-python/pexpect[$(python_gen_usedep python{2_6,2_7,3_2,3_3,3_4})]
+ $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 'python*')
dev-python/pyyaml[${PYTHON_USEDEP}]
)
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"