summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-07-03 16:36:32 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-07-03 16:36:32 +0000
commit536d8731a28481f5db9cf5cb7464b805c569a2a7 (patch)
tree9c7f0cf3963baeaa69d88259c8e9e3353660e2e0 /dev-python/python-ldap/python-ldap-2.0.1.ebuild
parentMark stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-536d8731a28481f5db9cf5cb7464b805c569a2a7.tar.gz
gentoo-2-536d8731a28481f5db9cf5cb7464b805c569a2a7.tar.bz2
gentoo-2-536d8731a28481f5db9cf5cb7464b805c569a2a7.zip
Version bump.
Diffstat (limited to 'dev-python/python-ldap/python-ldap-2.0.1.ebuild')
-rw-r--r--dev-python/python-ldap/python-ldap-2.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-ldap/python-ldap-2.0.1.ebuild b/dev-python/python-ldap/python-ldap-2.0.1.ebuild
new file mode 100644
index 000000000000..d071842ddb00
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.0.1.ebuild,v 1.1 2004/07/03 16:36:32 kloeri Exp $
+
+inherit distutils
+
+IUSE="sasl ssl"
+#MY_P=${P/_pre/pre}
+#S=${WORKDIR}/${MY_P}
+DESCRIPTION="Various LDAP-related Python modules"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://python-ldap.sourceforge.net/"
+
+DEPEND="virtual/python
+ >=net-nds/openldap-2.0.11
+ sasl? ( dev-libs/cyrus-sasl )"
+
+SLOT="0"
+LICENSE="PYTHON"
+KEYWORDS="~x86 ~sparc ~alpha"
+
+PYTHON_MODNAME="ldap"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s|/usr/local/openldap.*/lib|/usr/lib|" \
+ -e "s|/usr/local/openldap.*/include|/usr/include|" \
+ -i setup.cfg || die "error fixing setup.cfg"
+
+ local mylibs
+ use sasl \
+ && mylibs="${mylibs} sasl2 ldap" \
+ || mylibs="${mylibs} ldap"
+
+ # Fixes bug #25693
+ sed -e "s|<sasl.h>|<sasl/sasl.h>|" -i Modules/LDAPObject.c
+
+ use ssl && mylibs="${mylibs} ssl crypto"
+ sed -e "s|^libs = .*|libs = lber resolv ${mylibs}|" \
+ -e "s|^compile.*|compile = 0|" \
+ -e "s|^optimize.*|optimize = 0|" \
+ -i setup.cfg || die "error setting up libs in setup.cfg"
+}