summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-01 10:35:21 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-01 10:35:21 +0000
commit1e9287b92c8ee4f239fc7f978a8528f0e91db0bc (patch)
treec10daeec9a3c3028bffa3eca2ef764d13da7414d /dev-python/python-ldap
parentversion bump and added useflags (diff)
downloadgentoo-2-1e9287b92c8ee4f239fc7f978a8528f0e91db0bc.tar.gz
gentoo-2-1e9287b92c8ee4f239fc7f978a8528f0e91db0bc.tar.bz2
gentoo-2-1e9287b92c8ee4f239fc7f978a8528f0e91db0bc.zip
version bump and added useflags
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/ChangeLog9
-rw-r--r--dev-python/python-ldap/Manifest4
-rw-r--r--dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre131
-rw-r--r--dev-python/python-ldap/python-ldap-2.0.0_pre13.ebuild34
4 files changed, 45 insertions, 3 deletions
diff --git a/dev-python/python-ldap/ChangeLog b/dev-python/python-ldap/ChangeLog
index 75c9b2da9f31..49327860a976 100644
--- a/dev-python/python-ldap/ChangeLog
+++ b/dev-python/python-ldap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-ldap
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.9 2003/05/22 08:53:08 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.10 2003/07/01 10:35:12 liquidx Exp $
+
+*python-ldap-2.0.0_pre13 (01 Jul 2003)
+
+ 01 Jul 2003; Alastair Tse <liquidx@gentoo.org>
+ python-ldap-2.0.0_pre13.ebuild:
+ version bump. adds sasl and ssl USE flags to correspond with openldap's USE
+ flags
22 May 2003; Alastair Tse <liquidx@gentoo.org>
python-ldap-2.0.0_pre06.ebuild:
diff --git a/dev-python/python-ldap/Manifest b/dev-python/python-ldap/Manifest
index 8f1eb55cea20..bdaa5e62311c 100644
--- a/dev-python/python-ldap/Manifest
+++ b/dev-python/python-ldap/Manifest
@@ -1,8 +1,8 @@
-MD5 0fed88f081f8b1640437a83f6d73b86e ChangeLog 1127
+MD5 daa7f24e4132d70bbf929b18e15f765d ChangeLog 1338
MD5 52d9b77c8442a4239473404e0d240987 python-ldap-2.0.0_pre05-r1.ebuild 921
MD5 d0016cfcd05cb6b30a0469eafa577057 python-ldap-2.0.0_pre05.ebuild 848
MD5 937f37d1704f72e2b95a3194a9ac0afa python-ldap-2.0.0_pre06.ebuild 875
-MD5 691c4b3baa3683b3bbd65e98ae524141 python-ldap-2.0.0_pre13.ebuild 878
+MD5 3a9c755df7a12071884584b086e4f45a python-ldap-2.0.0_pre13.ebuild 1051
MD5 870f1b1ecea4f738da0ba65fb5a0a661 files/digest-python-ldap-2.0.0_pre05 73
MD5 870f1b1ecea4f738da0ba65fb5a0a661 files/digest-python-ldap-2.0.0_pre05-r1 73
MD5 aaef21adf6aa58c8fc0a0627f3ceae5f files/digest-python-ldap-2.0.0_pre06 73
diff --git a/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre13 b/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre13
new file mode 100644
index 000000000000..527ff8e678d4
--- /dev/null
+++ b/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre13
@@ -0,0 +1 @@
+MD5 ec69151b7d674f99f7498df9763eced7 python-ldap-2.0.0pre13.tar.gz 62480
diff --git a/dev-python/python-ldap/python-ldap-2.0.0_pre13.ebuild b/dev-python/python-ldap/python-ldap-2.0.0_pre13.ebuild
new file mode 100644
index 000000000000..4fdcc5aa178a
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.0.0_pre13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.0.0_pre13.ebuild,v 1.1 2003/07/01 10:35:12 liquidx Exp $
+
+inherit distutils
+
+IUSE="sasl ssl"
+MY_P=${P/_pre/pre}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Various LDAP-related Python modules"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://python-ldap.sourceforge.net/"
+
+DEPEND="virtual/python
+ >=net-nds/openldap-2.0.11"
+SLOT="0"
+LICENSE="public-domain" # NOTE: win32 section is under questionable license
+KEYWORDS="~x86 ~sparc ~alpha"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s|/usr/local/openldap.*/lib|/usr/lib|" \
+ -e "s|/usr/local/openldap.*/include|/usr/include|" \
+ -i setup.cfg || die "error fixing setup.cfg"
+
+ local mylibs
+ use sasl && mylibs="${mylibs} sasl2"
+ use ssl && mylibs="${mylibs} ssl crypto"
+ sed -e "s|^libs = .*|libs = ldap_r lber resolv ${mylibs}|" -i setup.cfg \
+ || die "error setting up libs in setup.cfg"
+
+}
+