summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-01 06:45:42 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-01 06:45:42 +0000
commit1a732c30ac3e4ab4df7f97c1dabbbaa863d45e98 (patch)
tree5ebee475338e7e6b9f07970c328299aea0daa554 /dev-python/python-novaclient
parentrefactor into distutils-r1 and eapi5 (diff)
downloadgentoo-2-1a732c30ac3e4ab4df7f97c1dabbbaa863d45e98.tar.gz
gentoo-2-1a732c30ac3e4ab4df7f97c1dabbbaa863d45e98.tar.bz2
gentoo-2-1a732c30ac3e4ab4df7f97c1dabbbaa863d45e98.zip
better test support and eapi5 and distutils-r1 :D
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-novaclient')
-rw-r--r--dev-python/python-novaclient/ChangeLog9
-rw-r--r--dev-python/python-novaclient/python-novaclient-9999.ebuild29
2 files changed, 25 insertions, 13 deletions
diff --git a/dev-python/python-novaclient/ChangeLog b/dev-python/python-novaclient/ChangeLog
index 2a3b2a093cca..ff2d86a40197 100644
--- a/dev-python/python-novaclient/ChangeLog
+++ b/dev-python/python-novaclient/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for dev-python/python-novaclient
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-novaclient/ChangeLog,v 1.1 2012/12/31 18:25:42 prometheanfire Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-novaclient/ChangeLog,v 1.2 2013/01/01 06:45:42 prometheanfire Exp $
+
+ 01 Jan 2013; Matthew Thode <prometheanfire@gentoo.org>
+ python-novaclient-9999.ebuild:
+ better test support and eapi5 and distutils-r1 :D
*python-novaclient-9999 (31 Dec 2012)
31 Dec 2012; Matthew Thode <prometheanfire@gentoo.org>
+python-novaclient-9999.ebuild, +metadata.xml:
initial add of python-novaclient
-
diff --git a/dev-python/python-novaclient/python-novaclient-9999.ebuild b/dev-python/python-novaclient/python-novaclient-9999.ebuild
index dbdc0f930939..94ba1e5d27f5 100644
--- a/dev-python/python-novaclient/python-novaclient-9999.ebuild
+++ b/dev-python/python-novaclient/python-novaclient-9999.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-novaclient/python-novaclient-9999.ebuild,v 1.1 2012/12/31 18:25:42 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-novaclient/python-novaclient-9999.ebuild,v 1.2 2013/01/01 06:45:42 prometheanfire Exp $
-EAPI=3
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+EAPI=5
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-inherit distutils git-2
+inherit distutils-r1 git-2
EGIT_REPO_URI="git://github.com/openstack/${PN}.git
https://github.com/openstack/${PN}.git"
@@ -21,10 +19,21 @@ SLOT="0"
KEYWORDS=""
IUSE="test"
-DEPEND="dev-python/setuptools
- test? ( dev-python/nose
- dev-python/mock )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/iso8601
+ dev-python/mock
+ dev-python/nose
+ dev-python/prettytable
+ dev-python/pytest
+ dev-python/pytest-runner
+ dev-python/requests
+ dev-python/simplejson
+ dev-python/unittest2 )"
RDEPEND="virtual/python-argparse
dev-python/httplib2
dev-python/prettytable
dev-python/simplejson"
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die
+}