summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-25 10:35:27 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-25 10:35:27 +0000
commitc8acc4cbad9aa1723861c3a2e0138e849572d441 (patch)
treeae12b68de3463f25e4bb4ab57cd3324a8144de85 /dev-python/python-openid
parentVersion bump. (diff)
downloadgentoo-2-c8acc4cbad9aa1723861c3a2e0138e849572d441.tar.gz
gentoo-2-c8acc4cbad9aa1723861c3a2e0138e849572d441.tar.bz2
gentoo-2-c8acc4cbad9aa1723861c3a2e0138e849572d441.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r1 x86_64)
Diffstat (limited to 'dev-python/python-openid')
-rw-r--r--dev-python/python-openid/ChangeLog7
-rw-r--r--dev-python/python-openid/python-openid-2.2.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/python-openid/ChangeLog b/dev-python/python-openid/ChangeLog
index 54f1677c10de..276ca9f2fa66 100644
--- a/dev-python/python-openid/ChangeLog
+++ b/dev-python/python-openid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-openid
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.7 2008/03/13 04:00:57 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/ChangeLog,v 1.8 2008/06/25 10:35:27 hawking Exp $
+
+*python-openid-2.2.0 (25 Jun 2008)
+
+ 25 Jun 2008; Ali Polatel <hawking@gentoo.org> +python-openid-2.2.0.ebuild:
+ Version bump.
*python-openid-2.1.1 (13 Mar 2008)
diff --git a/dev-python/python-openid/python-openid-2.2.0.ebuild b/dev-python/python-openid/python-openid-2.2.0.ebuild
new file mode 100644
index 000000000000..d084bbea3feb
--- /dev/null
+++ b/dev-python/python-openid/python-openid-2.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-openid/python-openid-2.2.0.ebuild,v 1.1 2008/06/25 10:35:27 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="OpenID support for servers and consumers."
+HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/"
+SRC_URI="http://www.openidenabled.com/files/${PN}/packages/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples mysql postgres sqlite"
+
+RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )
+ || ( >=dev-lang/python-2.5 dev-python/pycrypto )
+ sqlite? (
+ || ( >=dev-lang/python-2.5 >=dev-python/pysqlite-2 )
+ )
+ postgres? ( dev-python/psycopg )
+ mysql? ( >=dev-python/mysql-python-1.2.2 )"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="openid"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #Patch to fix confusion with localhost/127.0.0.1
+ epatch "${FILESDIR}"/${PN}-2.0.0-gentoo-test_fetchers.diff
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml doc/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ #Remove test that requires running db server
+ sed -e '/storetest/d' -i admin/runtests
+
+ "${python}" admin/runtests || die "tests failed"
+}