summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-11-19 14:51:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-11-19 14:51:46 +0000
commit66c0d67f20bb92503d69adec48c67cb4824f3dcc (patch)
treec9e79148a2f8ed871914581dae8ed2f8a90c82da /dev-python/python-poppler-qt4
parentVersion bump. (diff)
downloadgentoo-2-66c0d67f20bb92503d69adec48c67cb4824f3dcc.tar.gz
gentoo-2-66c0d67f20bb92503d69adec48c67cb4824f3dcc.tar.bz2
gentoo-2-66c0d67f20bb92503d69adec48c67cb4824f3dcc.zip
old
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-python/python-poppler-qt4')
-rw-r--r--dev-python/python-poppler-qt4/ChangeLog7
-rw-r--r--dev-python/python-poppler-qt4/files/python-poppler-qt4-0.16.2-poppler020.patch383
-rw-r--r--dev-python/python-poppler-qt4/python-poppler-qt4-0.16.2.ebuild30
3 files changed, 6 insertions, 414 deletions
diff --git a/dev-python/python-poppler-qt4/ChangeLog b/dev-python/python-poppler-qt4/ChangeLog
index 1f0e3eb13040..956ec3aa4e13 100644
--- a/dev-python/python-poppler-qt4/ChangeLog
+++ b/dev-python/python-poppler-qt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-poppler-qt4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler-qt4/ChangeLog,v 1.4 2012/11/19 14:49:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler-qt4/ChangeLog,v 1.5 2012/11/19 14:51:46 ssuominen Exp $
+
+ 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
+ -python-poppler-qt4-0.16.2.ebuild,
+ -files/python-poppler-qt4-0.16.2-poppler020.patch:
+ old
*python-poppler-qt4-0.16.3 (19 Nov 2012)
diff --git a/dev-python/python-poppler-qt4/files/python-poppler-qt4-0.16.2-poppler020.patch b/dev-python/python-poppler-qt4/files/python-poppler-qt4-0.16.2-poppler020.patch
deleted file mode 100644
index 569cb34988c7..000000000000
--- a/dev-python/python-poppler-qt4/files/python-poppler-qt4-0.16.2-poppler020.patch
+++ /dev/null
@@ -1,383 +0,0 @@
---- poppler-qt4.sip
-+++ poppler-qt4.sip
-@@ -9,6 +9,8 @@
- POPPLER_V0_12_1
- POPPLER_V0_14_0
- POPPLER_V0_16_0
-+ POPPLER_V0_18_0
-+ POPPLER_V0_20_0
- }
-
- %Include types.sip
---- poppler-annotation.sip
-+++ poppler-annotation.sip
-@@ -45,6 +45,7 @@
- void setFlags( int flags );
- QRectF boundary() const;
- void setBoundary( const QRectF &boundary );
-+%If(- POPPLER_V0_18_0)
- struct Style {
- // appearance properties
- QColor color; // black
-@@ -92,12 +93,18 @@
-
- // QLinkedList< Poppler::Annotation::Revision >& revisions();
- const QLinkedList< Poppler::Annotation::Revision >& revisions() const;
-+%End
- virtual SubType subType() const = 0;
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode & parentNode, QDomDocument & document ) const;
-+%End
- virtual ~Annotation();
-
- private:
- Annotation(const Poppler::Annotation&);
-+%If(POPPLER_V0_20_0 -)
-+ virtual void store( QDomNode & parentNode, QDomDocument & document ) const;
-+%End
-
- %ConvertToSubClassCode
- switch (sipCpp->subType()) {
-@@ -151,17 +158,23 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- TextAnnotation();
- TextAnnotation( const QDomNode &node );
-+%End
- virtual ~TextAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
-
- enum TextType { Linked, InPlace };
- enum InplaceIntent { Unknown, Callout, TypeWriter };
-
- TextType textType() const;
-+%If(- POPPLER_V0_18_0)
- void setTextType( TextType type );
-+%End
-
- QString textIcon() const;
- void setTextIcon( const QString &icon );
-@@ -176,12 +189,20 @@
- void setInplaceText( const QString &text );
-
- QPointF calloutPoint( int id ) const;
-+%If(- POPPLER_V0_18_0)
- void setCalloutPoint( int id, const QPointF &point );
-+%End
-
- InplaceIntent inplaceIntent() const;
- void setInplaceIntent( InplaceIntent intent );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ TextAnnotation();
-+ TextAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+ void setTextType( TextType type );
-+%End
- TextAnnotation(const Poppler::TextAnnotation&);
-
- }; // class TextAnnotation
-@@ -194,10 +215,14 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- LineAnnotation();
- LineAnnotation( const QDomNode &node );
-+%End
- virtual ~LineAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
-
- enum TermStyle { Square, Circle, Diamond, OpenArrow, ClosedArrow, None,
-@@ -232,6 +257,11 @@
- void setLineIntent( LineIntent intent );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ LineAnnotation();
-+ LineAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- LineAnnotation(const Poppler::LineAnnotation&);
-
- }; // class LineAnnotation
-@@ -244,10 +274,14 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- GeomAnnotation();
- GeomAnnotation( const QDomNode &node );
-+%End
- virtual ~GeomAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
-
- enum GeomType { InscribedSquare, InscribedCircle };
-@@ -258,10 +292,17 @@
- QColor geomInnerColor() const;
- void setGeomInnerColor( const QColor &color );
-
-+%If(- POPPLER_V0_18_0)
- int geomPointWidth() const;
- void setGeomPointWidth( int width );
-+%End
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ GeomAnnotation();
-+ GeomAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- GeomAnnotation(const Poppler::GeomAnnotation&);
-
- }; // class GeomAnnotation
-@@ -274,10 +315,14 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- HighlightAnnotation();
- HighlightAnnotation( const QDomNode &node );
-+%End
- virtual ~HighlightAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
- enum HighlightType {
- Highlight,
-@@ -341,6 +386,11 @@
- void setHighlightQuads( const QList< Poppler::HighlightAnnotation::Quad > &quads );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ HighlightAnnotation();
-+ HighlightAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- HighlightAnnotation(const Poppler::HighlightAnnotation&);
-
- }; // class HighlightAnnotation
-@@ -353,13 +403,25 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- StampAnnotation();
- StampAnnotation( const QDomNode &node );
-+%End
- virtual ~StampAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
- QString stampIconName() const;
- void setStampIconName( const QString &name );
-+
-+private:
-+%If(POPPLER_V0_20_0 -)
-+ StampAnnotation();
-+ StampAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
-+
- }; // class StampAnnotation
-
-
-@@ -370,15 +432,24 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- InkAnnotation();
- InkAnnotation( const QDomNode &node );
-+%End
- virtual ~InkAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
- QList< QLinkedList<QPointF> > inkPaths() const;
- void setInkPaths( const QList< QLinkedList<QPointF> > &paths );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ InkAnnotation();
-+ InkAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- InkAnnotation(const Poppler::InkAnnotation&);
-
- }; // class InkAnnotation
-@@ -391,15 +462,24 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- LinkAnnotation();
- LinkAnnotation( const QDomNode &node );
-+%End
- virtual ~LinkAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
-
- enum HighlightMode { None, Invert, Outline, Push };
-
-+%If(- POPPLER_V0_18_0)
- Poppler::Link* linkDestionation() const;
-+%End
-+%If(POPPLER_V0_20_0 -)
-+ Poppler::Link* linkDestination() const;
-+%End
- void setLinkDestination( Poppler::Link *link );
-
- HighlightMode linkHighlightMode() const;
-@@ -409,6 +489,11 @@
- void setLinkRegionPoint( int id, const QPointF &point );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ LinkAnnotation();
-+ LinkAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- LinkAnnotation(const Poppler::LinkAnnotation&);
-
- }; // class LinkAnnotation
-@@ -421,16 +506,25 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- CaretAnnotation();
- CaretAnnotation( const QDomNode &node );
-+%End
- virtual ~CaretAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
- enum CaretSymbol { None, P };
- CaretSymbol caretSymbol() const;
- void setCaretSymbol( CaretSymbol symbol );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ CaretAnnotation();
-+ CaretAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- CaretAnnotation(const Poppler::CaretAnnotation&);
-
- }; // class CaretAnnotation
-@@ -443,10 +537,14 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- FileAttachmentAnnotation();
- FileAttachmentAnnotation( const QDomNode &node );
-+%End
- virtual ~FileAttachmentAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
- QString fileIconName() const;
- void setFileIconName( const QString &icon );
-@@ -454,6 +552,11 @@
- void setEmbeddedFile( Poppler::EmbeddedFile *ef );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ FileAttachmentAnnotation();
-+ FileAttachmentAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- FileAttachmentAnnotation(const Poppler::FileAttachmentAnnotation&);
-
- }; // class FileAttachmentAnnotation
-@@ -466,10 +569,14 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- SoundAnnotation();
- SoundAnnotation( const QDomNode &node );
-+%End
- virtual ~SoundAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
- QString soundIconName() const;
- void setSoundIconName( const QString &icon );
-@@ -477,6 +584,11 @@
- void setSound( Poppler::SoundObject *ef );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ SoundAnnotation();
-+ SoundAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- SoundAnnotation(const Poppler::SoundAnnotation&);
-
- }; // class SoundAnnotation
-@@ -489,10 +601,14 @@
- %End
-
- public:
-+%If(- POPPLER_V0_18_0)
- MovieAnnotation();
- MovieAnnotation( const QDomNode &node );
-+%End
- virtual ~MovieAnnotation();
-+%If(- POPPLER_V0_18_0)
- virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- virtual SubType subType() const;
-
- Poppler::MovieObject* movie() const;
-@@ -501,6 +617,11 @@
- void setMovieTitle( const QString &title );
-
- private:
-+%If(POPPLER_V0_20_0 -)
-+ MovieAnnotation();
-+ MovieAnnotation( const QDomNode &node );
-+ virtual void store( QDomNode &parentNode, QDomDocument &document ) const;
-+%End
- MovieAnnotation(const Poppler::MovieAnnotation&);
-
- }; // class MovieAnnotation
---- setup.py
-+++ setup.py
-@@ -131,8 +131,12 @@
- tag = 'POPPLER_V0_12_1'
- elif ver < (0, 16, 0):
- tag = 'POPPLER_V0_14_0'
-+ elif ver < (0, 18, 0):
-+ tag = 'POPPLER_V0_16_0'
-+ elif ver < (0, 20, 0):
-+ tag = 'POPPLER_V0_18_0'
- else:
-- tag = 'POPPLER_V0_16_0'
-+ tag = 'POPPLER_V0_20_0'
-
- cmd = [sip_bin]
- if hasattr(self, 'sip_opts'):
diff --git a/dev-python/python-poppler-qt4/python-poppler-qt4-0.16.2.ebuild b/dev-python/python-poppler-qt4/python-poppler-qt4-0.16.2.ebuild
deleted file mode 100644
index 0ce894fa9d2c..000000000000
--- a/dev-python/python-poppler-qt4/python-poppler-qt4-0.16.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-poppler-qt4/python-poppler-qt4-0.16.2.ebuild,v 1.3 2012/08/09 09:40:54 patrick Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.* *-pypy-*"
-
-inherit distutils eutils
-
-DESCRIPTION="A python binding for libpoppler-qt4"
-HOMEPAGE="http://code.google.com/p/python-poppler-qt4/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="app-text/poppler[qt4]
- dev-python/PyQt4
- >=dev-python/sip-4.9.1"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-poppler020.patch
- distutils_src_prepare
-}