summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-21 13:52:35 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-21 13:52:35 +0000
commit37f57501f93f19c6993b176d8dabdc644142fbab (patch)
tree80a571707aa03594a397171a144ee78c50a24131 /dev-python/pyxattr
parentFix pkg_preinst function, wrt bug #447954 (non-maintainer commit) (diff)
downloadgentoo-2-37f57501f93f19c6993b176d8dabdc644142fbab.tar.gz
gentoo-2-37f57501f93f19c6993b176d8dabdc644142fbab.tar.bz2
gentoo-2-37f57501f93f19c6993b176d8dabdc644142fbab.zip
Migrate to distutils-r1. Partially address xattr-related test failures.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/ChangeLog8
-rw-r--r--dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild36
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/pyxattr/ChangeLog b/dev-python/pyxattr/ChangeLog
index 12f9fcc21116..328126f63f52 100644
--- a/dev-python/pyxattr/ChangeLog
+++ b/dev-python/pyxattr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyxattr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.33 2012/06/14 22:11:17 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/ChangeLog,v 1.34 2012/12/21 13:52:35 mgorny Exp $
+
+*pyxattr-0.5.0-r1 (21 Dec 2012)
+
+ 21 Dec 2012; Michał Górny <mgorny@gentoo.org> +pyxattr-0.5.0-r1.ebuild:
+ Migrate to distutils-r1. Partially address xattr-related test failures.
14 Jun 2012; Anthony G. Basile <blueness@gentoo.org> pyxattr-0.5.0.ebuild:
Keyword ~mips, bug #402215
@@ -113,4 +118,3 @@
21 Sep 2005; Robin H. Johnson <robbat2@gentoo.org> +pyxattr-0.2.ebuild:
Initial commit, ebuild submitted by Thomas Bettler
<bettlertho@sis.unibe.ch>, dependancy for new rdiff-backup.
-
diff --git a/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild b/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..148b4a667d34
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.5.0-r1.ebuild,v 1.1 2012/12/21 13:52:35 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="http://sourceforge.net/projects/pyxattr/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="sys-apps/attr"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+src_test() {
+ # Perform the tests in /var/tmp; that location is more likely
+ # to have xattr support than /tmp which is often tmpfs.
+ export TESTDIR=/var/tmp
+
+ einfo 'Please note that the tests fail if xattrs are not supported'
+ einfo 'by the filesystem used for /var/tmp.'
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}