summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-09 19:03:20 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-09 19:03:20 +0000
commit09f371e734addbf6dc2c0f2c4e23aee8dc630ab7 (patch)
tree7f5e1514d98957d0646785083740a53ee43857d5 /dev-python/qscintilla-python
parentstable x86, bug 272334 (diff)
downloadgentoo-2-09f371e734addbf6dc2c0f2c4e23aee8dc630ab7.tar.gz
gentoo-2-09f371e734addbf6dc2c0f2c4e23aee8dc630ab7.tar.bz2
gentoo-2-09f371e734addbf6dc2c0f2c4e23aee8dc630ab7.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog8
-rw-r--r--dev-python/qscintilla-python/files/qscintilla-python-2.4-nostrip.patch22
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.ebuild48
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index c60f9d725a14..6db07f974184 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.23 2009/06/01 22:10:04 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.24 2009/06/09 19:03:20 hwoarang Exp $
+
+*qscintilla-python-2.4 (09 Jun 2009)
+
+ 09 Jun 2009; Markos Chandras <hwoarang@gentoo.org>
+ +qscintilla-python-2.4.ebuild, +files/qscintilla-python-2.4-nostrip.patch:
+ Version bump
01 Jun 2009; Ben de Groot <yngwin@gentoo.org>
qscintilla-python-2.3.2-r1.ebuild:
diff --git a/dev-python/qscintilla-python/files/qscintilla-python-2.4-nostrip.patch b/dev-python/qscintilla-python/files/qscintilla-python-2.4-nostrip.patch
new file mode 100644
index 000000000000..aa5f88a1e756
--- /dev/null
+++ b/dev-python/qscintilla-python/files/qscintilla-python-2.4-nostrip.patch
@@ -0,0 +1,22 @@
+--- Python/configure.py.orig 2009-05-13 23:54:57.000000000 +0200
++++ Python/configure.py 2009-05-13 23:56:26.000000000 +0200
+@@ -276,7 +276,8 @@
+ installs=installs,
+ static=opts.static,
+ debug=opts.debug,
+- universal=pyqt.universal
++ universal=pyqt.universal,
++ strip=0
+ )
+ else:
+ makefile = Makefile(
+@@ -285,7 +286,8 @@
+ install_dir=opts.qscimoddir,
+ installs=installs,
+ static=opts.static,
+- debug=opts.debug
++ debug=opts.debug,
++ strip=0
+ )
+
+ if qsci_define:
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
new file mode 100644
index 000000000000..eee5996bfd71
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.ebuild,v 1.1 2009/06/09 19:03:20 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils multilib python
+
+MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +qt4"
+
+DEPEND=">=dev-python/sip-4.8
+ ~x11-libs/qscintilla-${PV}[qt4=]
+ qt4? ( >=dev-python/PyQt4-4.5 )
+ !qt4? ( >=dev-python/PyQt-3.18 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}/Python
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4-nostrip.patch
+}
+
+src_configure() {
+ python_version
+
+ local myconf="${python} configure.py
+ --destdir=$(python_get_sitedir)/PyQt$(use qt4 && echo 4)
+ -n /usr/include
+ -o /usr/$(get_libdir)
+ -p $(use qt4 && echo 4 || echo 3)
+ $(use debug && echo '--debug')"
+ echo ${myconf}
+ ${myconf} || die "configuration failed"
+}
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+}