summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-26 19:26:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-26 19:26:24 +0000
commit1909854a0d6070c1427a2fa4b06d16478c2e8a3e (patch)
treefa240f18b928e33ba4f1e30f150379c9f206782c /dev-python/qscintilla-python
parentDelete older ebuild. (diff)
downloadgentoo-2-1909854a0d6070c1427a2fa4b06d16478c2e8a3e.tar.gz
gentoo-2-1909854a0d6070c1427a2fa4b06d16478c2e8a3e.tar.bz2
gentoo-2-1909854a0d6070c1427a2fa4b06d16478c2e8a3e.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild
deleted file mode 100644
index b702754a1043..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild,v 1.10 2010/12/19 19:03:27 arfrever Exp $
-
-EAPI="2"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils python toolchain-funcs
-
-MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug"
-
-DEPEND=">=dev-python/sip-4.10
- >=dev-python/PyQt4-4.7[X]
- ~x11-libs/qscintilla-${PV}"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}/Python"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.4-nostrip.patch
-
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py -p 4
- --destdir=$(python_get_sitedir)/PyQt4
- $(use debug && echo '--debug')"
- echo ${myconf}
- ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- building() {
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
- }
- python_execute_function -s building
-}