summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-16 14:10:30 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-16 14:10:30 +0000
commit1fdc6ee9e34b3cd70ac3f19d1258c054a3f11173 (patch)
treecd107e4239e94560fec82f196453e76c04390b1c /dev-python/reportlab
parentcleanup old ebuilds and stable bump (diff)
downloadgentoo-2-1fdc6ee9e34b3cd70ac3f19d1258c054a3f11173.tar.gz
gentoo-2-1fdc6ee9e34b3cd70ac3f19d1258c054a3f11173.tar.bz2
gentoo-2-1fdc6ee9e34b3cd70ac3f19d1258c054a3f11173.zip
version bump. (#135494). changed license to BSD.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/ChangeLog13
-rw-r--r--dev-python/reportlab/files/digest-reportlab-2.03
-rw-r--r--dev-python/reportlab/reportlab-2.0.ebuild49
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/reportlab/ChangeLog b/dev-python/reportlab/ChangeLog
index 6ed631586539..10620e8d4a4b 100644
--- a/dev-python/reportlab/ChangeLog
+++ b/dev-python/reportlab/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-python/reportlab
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v 1.31 2006/06/27 22:53:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/ChangeLog,v 1.32 2006/07/16 14:10:30 liquidx Exp $
+
+*reportlab-2.0 (16 Jul 2006)
+
+ 16 Jul 2006; Alastair Tse <liquidx@gentoo.org> -reportlab-1.14.ebuild,
+ -reportlab-1.17-r1.ebuild, -reportlab-1.18.ebuild, -reportlab-1.19.ebuild,
+ +reportlab-2.0.ebuild:
+ version bump. (#135494). changed license to BSD.
+
+ 16 Jul 2006; Alastair Tse <liquidx@gentoo.org> -reportlab-1.14.ebuild,
+ -reportlab-1.17-r1.ebuild, -reportlab-1.18.ebuild, -reportlab-1.19.ebuild:
+ cleanup old ebuilds
27 Jun 2006; Jeroen Roovers <jer@gentoo.org> reportlab-1.20.ebuild:
Marked ~hppa (for inkscape).
diff --git a/dev-python/reportlab/files/digest-reportlab-2.0 b/dev-python/reportlab/files/digest-reportlab-2.0
new file mode 100644
index 000000000000..a3a6a52376c1
--- /dev/null
+++ b/dev-python/reportlab/files/digest-reportlab-2.0
@@ -0,0 +1,3 @@
+MD5 0de80cdf310dac692ba6ea02beb4481b ReportLab_2_0.tgz 2411766
+RMD160 e8e9b54a1f2d657d85666e6bf688129469f2e3e2 ReportLab_2_0.tgz 2411766
+SHA256 b723719b1a42403bb5e28a35f1173ef267e9f08d4a6c78a8cb730d5dd73ad3c0 ReportLab_2_0.tgz 2411766
diff --git a/dev-python/reportlab/reportlab-2.0.ebuild b/dev-python/reportlab/reportlab-2.0.ebuild
new file mode 100644
index 000000000000..c7dfafa4b5f7
--- /dev/null
+++ b/dev-python/reportlab/reportlab-2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-2.0.ebuild,v 1.1 2006/07/16 14:10:30 liquidx Exp $
+
+#goofy tarball versioning
+vmaj=${PV%%.*}
+vmin=${PV##*.}
+
+inherit python distutils
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Tools for generating printable PDF documents from any data source."
+SRC_URI="http://www.reportlab.org/ftp/ReportLab_${vmaj}_${vmin}.tgz"
+HOMEPAGE="http://www.reportlab.org/"
+
+DEPEND=">=dev-lang/python-2.4.2
+ >=sys-libs/zlib-0.95
+ dev-python/imaging
+ >=sys-apps/sed-4
+ app-arch/tar"
+
+IUSE=""
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${WORKDIR}
+ mv ${PN}_${vmaj}_${vmin}/${PN} . || die
+ cd ${S}
+}
+
+src_install() {
+ python_version
+ distutils_src_install
+
+ # docs
+ cd ${S}
+ dodoc README license.txt
+ insinto /usr/share/doc/${PF}
+ doins docs/*
+}
+
+pkg_postinst() {
+ ewarn "There have been changes to fonts and unicode in 2.0"
+ ewarn "make sure you understand them:"
+ ewarn "http://www.reportlab.org/whatsnew_2_0.html"
+}