summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-09-25 09:18:23 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-09-25 09:18:23 +0000
commitc07f676dd1e79f98ac5fb8d1556c701c40330774 (patch)
treec85a82a24e437d7f48e1cf6b5282f9d74b437743 /dev-python/requests
parentRemove forced -O0 to -O3 from configure using sed in late src_prepare() (diff)
downloadgentoo-2-c07f676dd1e79f98ac5fb8d1556c701c40330774.tar.gz
gentoo-2-c07f676dd1e79f98ac5fb8d1556c701c40330774.tar.bz2
gentoo-2-c07f676dd1e79f98ac5fb8d1556c701c40330774.zip
Version bump requests to 2.0.0.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/ChangeLog7
-rw-r--r--dev-python/requests/requests-2.0.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index ed7957e619b0..1aca50373821 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.44 2013/09/25 08:04:14 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.45 2013/09/25 09:18:23 djc Exp $
+
+*requests-2.0.0 (25 Sep 2013)
+
+ 25 Sep 2013; Dirkjan Ochtman <djc@gentoo.org> +requests-2.0.0.ebuild:
+ Version bump requests to 2.0.0.
25 Sep 2013; Dirkjan Ochtman <djc@gentoo.org> -requests-0.14.2.ebuild,
-requests-1.0.4.ebuild, -requests-1.1.0.ebuild, -requests-1.2.0.ebuild,
diff --git a/dev-python/requests/requests-2.0.0.ebuild b/dev-python/requests/requests-2.0.0.ebuild
new file mode 100644
index 000000000000..db51082c6731
--- /dev/null
+++ b/dev-python/requests/requests-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-2.0.0.ebuild,v 1.1 2013/09/25 09:18:23 djc Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="test"
+
+# bundles dev-python/urllib3 snapshot
+RDEPEND="app-misc/ca-certificates
+ dev-python/charade[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# tests connect to various remote sites
+RESTRICT="test"
+
+DOCS=( README.rst HISTORY.rst )
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-system-cacerts.patch
+ "${FILESDIR}"/${PN}-1.2.0-system-libs.patch
+ )
+
+ # use system charade
+ rm -r requests/packages/charade || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}