summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-09 22:45:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-09 22:45:13 +0000
commite364a6b4f4f196e7a53ea43d0d353851465c78a8 (patch)
treef8417aa963b53de444595f8715f463a85d9a0a34 /dev-python/restrictedpython
parentDelete older ebuild. (diff)
downloadgentoo-2-e364a6b4f4f196e7a53ea43d0d353851465c78a8.tar.gz
gentoo-2-e364a6b4f4f196e7a53ea43d0d353851465c78a8.tar.bz2
gentoo-2-e364a6b4f4f196e7a53ea43d0d353851465c78a8.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/restrictedpython')
-rw-r--r--dev-python/restrictedpython/ChangeLog8
-rw-r--r--dev-python/restrictedpython/restrictedpython-3.6.0.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/restrictedpython/ChangeLog b/dev-python/restrictedpython/ChangeLog
index 97dce0545def..ccd01d2c55ba 100644
--- a/dev-python/restrictedpython/ChangeLog
+++ b/dev-python/restrictedpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/restrictedpython
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restrictedpython/ChangeLog,v 1.6 2010/05/06 23:36:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restrictedpython/ChangeLog,v 1.7 2010/07/09 22:45:13 arfrever Exp $
+
+*restrictedpython-3.6.0 (09 Jul 2010)
+
+ 09 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -restrictedpython-3.5.2.ebuild, +restrictedpython-3.6.0.ebuild:
+ Version bump.
*restrictedpython-3.5.2 (06 May 2010)
diff --git a/dev-python/restrictedpython/restrictedpython-3.6.0.ebuild b/dev-python/restrictedpython/restrictedpython-3.6.0.ebuild
new file mode 100644
index 000000000000..ecd4d7a20239
--- /dev/null
+++ b/dev-python/restrictedpython/restrictedpython-3.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restrictedpython/restrictedpython-3.6.0.ebuild,v 1.1 2010/07/09 22:45:13 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="RestrictedPython"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="RestrictedPython provides a restricted execution environment for Python, e.g. for running untrusted code."
+HOMEPAGE="http://pypi.python.org/pypi/RestrictedPython"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt src/RestrictedPython/README.txt"
+PYTHON_MODNAME="${MY_PN}"
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/RestrictedPython/tests"
+ }
+ python_execute_function delete_tests
+}