summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-29 02:24:28 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-29 02:24:28 +0000
commit5e6059da6e17d09d834e922051668f4b17fe5022 (patch)
tree09229cabe750c7bec14dd901fa0fa91f30cf0c9e /dev-python/routes
parentMask dev-python/wsgiref. (diff)
downloadgentoo-2-5e6059da6e17d09d834e922051668f4b17fe5022.tar.gz
gentoo-2-5e6059da6e17d09d834e922051668f4b17fe5022.tar.bz2
gentoo-2-5e6059da6e17d09d834e922051668f4b17fe5022.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14458-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/ChangeLog8
-rw-r--r--dev-python/routes/routes-1.11.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/routes/ChangeLog b/dev-python/routes/ChangeLog
index 3c4d51decc51..d64ea488dd25 100644
--- a/dev-python/routes/ChangeLog
+++ b/dev-python/routes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/routes
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.6 2009/09/04 17:37:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/ChangeLog,v 1.7 2009/09/29 02:24:28 arfrever Exp $
+
+*routes-1.11 (29 Sep 2009)
+
+ 29 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +routes-1.11.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
04 Sep 2009; Patrick Lauer <patrick@gentoo.org> -routes-1.6.3.ebuild,
-routes-1.8.ebuild:
diff --git a/dev-python/routes/routes-1.11.ebuild b/dev-python/routes/routes-1.11.ebuild
new file mode 100644
index 000000000000..a16a30818412
--- /dev/null
+++ b/dev-python/routes/routes-1.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.11.ebuild,v 1.1 2009/09/29 02:24:28 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions."
+HOMEPAGE="http://routes.groovie.org"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/buildutils dev-python/pudge )
+ test? ( dev-python/coverage dev-python/nose )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ PYTHONPATH=. "${python}" setup.py pudge || die "Generation of documentation failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r docs/html/*
+}