summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-31 20:10:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-31 20:10:05 +0000
commit36daffaf194be77b67ee3152fb1395d559225e20 (patch)
tree70a4fe5d1666701eca4670f52febf05126b10820 /dev-python/scientificpython
parentDelete older ebuild. (diff)
downloadgentoo-2-36daffaf194be77b67ee3152fb1395d559225e20.tar.gz
gentoo-2-36daffaf194be77b67ee3152fb1395d559225e20.tar.bz2
gentoo-2-36daffaf194be77b67ee3152fb1395d559225e20.zip
Version bump.
(Portage version: 2.2.0_alpha11_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/scientificpython')
-rw-r--r--dev-python/scientificpython/ChangeLog9
-rw-r--r--dev-python/scientificpython/files/scientificpython-2.9.1-mpi-netcdf.patch29
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.1.ebuild83
3 files changed, 120 insertions, 1 deletions
diff --git a/dev-python/scientificpython/ChangeLog b/dev-python/scientificpython/ChangeLog
index f8177afbd616..f6d0e7519641 100644
--- a/dev-python/scientificpython/ChangeLog
+++ b/dev-python/scientificpython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/scientificpython
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.33 2010/05/23 14:15:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/ChangeLog,v 1.34 2010/12/31 20:10:05 arfrever Exp $
+
+*scientificpython-2.9.1 (31 Dec 2010)
+
+ 31 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -scientificpython-2.9.ebuild, +scientificpython-2.9.1.ebuild,
+ +files/scientificpython-2.9.1-mpi-netcdf.patch:
+ Version bump.
23 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
scientificpython-2.9-r1.ebuild:
diff --git a/dev-python/scientificpython/files/scientificpython-2.9.1-mpi-netcdf.patch b/dev-python/scientificpython/files/scientificpython-2.9.1-mpi-netcdf.patch
new file mode 100644
index 000000000000..622032d4d174
--- /dev/null
+++ b/dev-python/scientificpython/files/scientificpython-2.9.1-mpi-netcdf.patch
@@ -0,0 +1,29 @@
+--- setup.py
++++ setup.py
+@@ -2,7 +2,7 @@
+
+ from distutils.core import setup, Extension
+ from distutils.command.install_headers import install_headers
+-import os, sys, platform
++import os, sys, platform, subprocess
+ from glob import glob
+
+ class Dummy:
+@@ -103,13 +103,16 @@
+ netcdf_include = os.path.join(netcdf_prefix, 'include')
+ netcdf_h_file = os.path.join(netcdf_prefix, 'include', 'netcdf.h')
+ netcdf_lib = os.path.join(netcdf_prefix, 'lib')
++ mpi_cflags = subprocess.Popen(["mpicc", "-showme:compile"], stdout=subprocess.PIPE).communicate()[0].rstrip().split()
++ mpi_ldflags = subprocess.Popen(["mpicc", "-showme:link"], stdout=subprocess.PIPE).communicate()[0].rstrip().split()
+ ext_modules = [Extension('Scientific_netcdf',
+ ['Src/Scientific_netcdf.c'],
+ include_dirs=['Include', netcdf_include]
+ + arrayobject_h_include,
+ library_dirs=[netcdf_lib],
+ libraries = ['netcdf'],
+- extra_compile_args=extra_compile_args)]
++ extra_compile_args=extra_compile_args + mpi_cflags,
++ extra_link_args=mpi_ldflags)]
+
+ try:
+ # Add code for including documentation in Mac packages
diff --git a/dev-python/scientificpython/scientificpython-2.9.1.ebuild b/dev-python/scientificpython/scientificpython-2.9.1.ebuild
new file mode 100644
index 000000000000..d8c1fb39a2cf
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.9.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scientificpython/scientificpython-2.9.1.ebuild,v 1.1 2010/12/31 20:10:05 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+MY_PN="ScientificPython"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Scientific Module for Python"
+DOWNLOAD_NUMBER="3420"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
+HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc mpi test"
+
+RDEPEND="dev-python/numpy
+ sci-libs/netcdf
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+PYTHON_MODNAME="Scientific"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-2.9-mpi.patch"
+ use mpi && epatch "${FILESDIR}/${P}-mpi-netcdf.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use mpi; then
+ cd Src/MPI
+ building_of_mpipython() {
+ PYTHONPATH="$(ls -d ../../build-${PYTHON_ABI}/lib*)" "$(PYTHON)" compile.py
+ mv -f mpipython mpipython-${PYTHON_ABI}
+ }
+ python_execute_function \
+ --action-message 'Building of mpipython with $(python_get_implementation) $(python_get_version)' \
+ --failure-message 'Building of mpipython failed with $(python_get_implementation) $(python_get_version)' \
+ building_of_mpipython
+ fi
+}
+
+src_test() {
+ cd Tests
+ python_execute_nosetests -P '$(ls -d ../build-${PYTHON_ABI}/lib.*)'
+}
+
+src_install() {
+ distutils_src_install
+ # do not install bsp related stuff, since we don't compile the interface
+ dodoc README README.MPI Doc/CHANGELOG || die "dodoc failed"
+ insinto /usr/share/doc/${PF}
+ doins Examples/{demomodule.c,netcdf_demo.py} || die "doins examples failed"
+
+ if use mpi; then
+ installation_of_mpipython() {
+ dobin Src/MPI/mpipython-${PYTHON_ABI}
+ }
+ python_execute_function -q installation_of_mpipython
+ python_generate_wrapper_scripts "${ED}usr/bin/mpipython"
+ doins Examples/mpi.py || die "doins mpi example failed failed"
+ fi
+
+ if use doc; then
+ dohtml Doc/Reference/* || die "dohtml failed"
+ fi
+}