summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-03 23:54:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-03 23:54:04 +0000
commit1921cde1908f90b5affca8d44c92f9f3f578d9fa (patch)
tree149d8ceb1245b779478f9939cfdeaa5f500c0597 /dev-python/scimath
parentVersion bump. Possible API break. (diff)
downloadgentoo-2-1921cde1908f90b5affca8d44c92f9f3f578d9fa.tar.gz
gentoo-2-1921cde1908f90b5affca8d44c92f9f3f578d9fa.tar.bz2
gentoo-2-1921cde1908f90b5affca8d44c92f9f3f578d9fa.zip
Version bump. Possible API break.
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/scimath')
-rw-r--r--dev-python/scimath/ChangeLog7
-rw-r--r--dev-python/scimath/scimath-4.0.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/scimath/ChangeLog b/dev-python/scimath/ChangeLog
index d61adcf6f095..e9ef15b9788c 100644
--- a/dev-python/scimath/ChangeLog
+++ b/dev-python/scimath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/scimath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.8 2011/01/30 15:27:32 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.9 2011/08/03 23:54:04 bicatali Exp $
+
+*scimath-4.0.0 (03 Aug 2011)
+
+ 03 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> +scimath-4.0.0.ebuild:
+ Version bump. Possible API break.
*scimath-3.0.7 (30 Jan 2011)
diff --git a/dev-python/scimath/scimath-4.0.0.ebuild b/dev-python/scimath/scimath-4.0.0.ebuild
new file mode 100644
index 000000000000..442df902675d
--- /dev/null
+++ b/dev-python/scimath/scimath-4.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.0.0.ebuild,v 1.1 2011/08/03 23:54:04 bicatali Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils virtualx
+
+DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
+HOMEPAGE="http://code.enthought.com/projects/sci_math/ http://pypi.python.org/pypi/scimath"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/traits-4.0
+ >=dev-python/traitsui-4.0
+ sci-libs/scipy"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE*.txt" -delete
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+}