summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-29 02:18:37 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-29 02:18:37 +0000
commit9f88ebc0e87f842d5d71e6ffd2034da141d76ded (patch)
treef2675692b4dd78aa19495caa024dc88d9cc94471 /dev-python/sexy-python
parentEnsure that defined functions are passed to python_execute_function(). Add PY... (diff)
downloadgentoo-2-9f88ebc0e87f842d5d71e6ffd2034da141d76ded.tar.gz
gentoo-2-9f88ebc0e87f842d5d71e6ffd2034da141d76ded.tar.bz2
gentoo-2-9f88ebc0e87f842d5d71e6ffd2034da141d76ded.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14166-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sexy-python')
-rw-r--r--dev-python/sexy-python/ChangeLog8
-rw-r--r--dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild31
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/sexy-python/ChangeLog b/dev-python/sexy-python/ChangeLog
index 19fefb9c55bd..a4ba5b454f82 100644
--- a/dev-python/sexy-python/ChangeLog
+++ b/dev-python/sexy-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sexy-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/ChangeLog,v 1.16 2009/05/31 23:23:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/ChangeLog,v 1.17 2009/08/29 02:18:37 arfrever Exp $
+
+*sexy-python-0.1.9-r1 (29 Aug 2009)
+
+ 29 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sexy-python-0.1.9-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
31 May 2009; Brent Baude <ranger@gentoo.org> sexy-python-0.1.9.ebuild:
Marking sexy-python-0.1.9 ppc64 for bug 267709
diff --git a/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild b/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..a5ebbd972fd0
--- /dev/null
+++ b/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild,v 1.1 2009/08/29 02:18:37 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python
+
+DESCRIPTION="Python bindings for libsexy."
+HOMEPAGE="http://www.chipx86.com/wiki/Libsexy"
+SRC_URI="http://releases.chipx86.com/libsexy/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/libsexy-${PV}
+ >=dev-python/pygtk-2.6.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_install() {
+ python_need_rebuild
+ python_execute_function -d -s
+ dodoc AUTHORS ChangeLog NEWS README
+}