summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-04-28 17:42:56 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-04-28 17:42:56 +0000
commitfeca89bad0b2c4953ce4346cf51154ddbb15feb3 (patch)
tree0fc6110386b076eaf43d11cfba1f0a284ce963d7 /dev-python/shiboken
parentComment out test relying on specific DNS results, bug 395155. (diff)
downloadgentoo-2-feca89bad0b2c4953ce4346cf51154ddbb15feb3.tar.gz
gentoo-2-feca89bad0b2c4953ce4346cf51154ddbb15feb3.tar.bz2
gentoo-2-feca89bad0b2c4953ce4346cf51154ddbb15feb3.zip
Version bump, ApiExtractor and GeneratorRunner have been merged into Shiboken. Switch to out-of-source build.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/ChangeLog8
-rw-r--r--dev-python/shiboken/shiboken-1.1.1.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index a50a23843fc4..ae54e3eff72e 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.24 2012/04/22 12:16:42 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.25 2012/04/28 17:42:56 pesa Exp $
+
+*shiboken-1.1.1 (28 Apr 2012)
+
+ 28 Apr 2012; Davide Pesavento <pesa@gentoo.org> +shiboken-1.1.1.ebuild:
+ Version bump, ApiExtractor and GeneratorRunner have been merged into Shiboken.
+ Switch to out-of-source build.
22 Apr 2012; Markus Meier <maekke@gentoo.org> shiboken-1.1.0-r2.ebuild:
x86 stable, bug #401789
diff --git a/dev-python/shiboken/shiboken-1.1.1.ebuild b/dev-python/shiboken/shiboken-1.1.1.ebuild
new file mode 100644
index 000000000000..854095edc602
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.1.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.1.ebuild,v 1.1 2012/04/28 17:42:56 pesa Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.1 *-jython 2.7-pypy-*"
+
+inherit multilib cmake-utils python
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.6.32
+ >=dev-libs/libxslt-1.1.19
+ >=x11-libs/qt-core-4.7.0:4
+ >=x11-libs/qt-xmlpatterns-4.7.0:4
+ !dev-python/apiextractor
+ !dev-python/generatorrunner
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=x11-libs/qt-gui-4.7.0:4
+ >=x11-libs/qt-test-4.7.0:4
+ )"
+
+DOCS=( AUTHORS ChangeLog )
+
+src_prepare() {
+ # Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
+ # caused by the usage of a different version suffix with python >= 3.2
+ sed -i -e "/get_config_var('SOABI')/d" \
+ cmake/Modules/FindPython3InterpWithDebug.cmake || die
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="$(PYTHON -a)"
+ -DPYTHON_SUFFIX="-python${PYTHON_ABI}"
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ if [[ $(python_get_version -l --major) == 3 ]]; then
+ mycmakeargs+=(
+ -DUSE_PYTHON3=ON
+ -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON3_LIBRARY="$(python_get_library)"
+ )
+ fi
+
+ CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_configure
+ }
+ python_execute_function configuration
+}
+
+src_compile() {
+ compilation() {
+ CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_make
+ }
+ python_execute_function compilation
+}
+
+src_test() {
+ testing() {
+ CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_test
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ installation() {
+ CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_install
+ mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-python${PYTHON_ABI}}.pc || die
+ }
+ python_execute_function installation
+}