summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-05-06 04:54:54 +0000
committerTim Harder <radhermit@gentoo.org>2014-05-06 04:54:54 +0000
commit9d65c9afebf94cd16d2c1657f929e992b9451223 (patch)
treefa609790369bf3bb3e8b84aaf972819f088f33c6 /dev-python/simplejson
parentRewrap long conditional dep line and quote python2 glob. (diff)
downloadgentoo-2-9d65c9afebf94cd16d2c1657f929e992b9451223.tar.gz
gentoo-2-9d65c9afebf94cd16d2c1657f929e992b9451223.tar.bz2
gentoo-2-9d65c9afebf94cd16d2c1657f929e992b9451223.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/ChangeLog7
-rw-r--r--dev-python/simplejson/simplejson-3.4.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/simplejson/ChangeLog b/dev-python/simplejson/ChangeLog
index 226b2d965781..d0d5d2a24c74 100644
--- a/dev-python/simplejson/ChangeLog
+++ b/dev-python/simplejson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/simplejson
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.126 2014/04/15 11:41:52 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/ChangeLog,v 1.127 2014/05/06 04:54:54 radhermit Exp $
+
+*simplejson-3.4.1 (06 May 2014)
+
+ 06 May 2014; Tim Harder <radhermit@gentoo.org> +simplejson-3.4.1.ebuild:
+ Version bump.
15 Apr 2014; Ian Delaney <idella4@gentoo.org> simplejson-3.4.0.ebuild:
correction to placement of DEPEND
diff --git a/dev-python/simplejson/simplejson-3.4.1.ebuild b/dev-python/simplejson/simplejson-3.4.1.ebuild
new file mode 100644
index 000000000000..43ad5e1b4b29
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-3.4.1.ebuild,v 1.1 2014/05/06 04:54:54 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson http://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}