summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-01 16:04:55 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-01 16:04:55 +0000
commit552ff8d8ba0753600e801f975ac6b8348aa423f5 (patch)
tree0cecd5d2534998bbf8a14ae1f260b1c2b3e0374b /dev-python/six/six-9999.ebuild
parentVersion bump. (diff)
downloadgentoo-2-552ff8d8ba0753600e801f975ac6b8348aa423f5.tar.gz
gentoo-2-552ff8d8ba0753600e801f975ac6b8348aa423f5.tar.bz2
gentoo-2-552ff8d8ba0753600e801f975ac6b8348aa423f5.zip
Add a live ebuild and a proper homepage.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/six/six-9999.ebuild')
-rw-r--r--dev-python/six/six-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/six/six-9999.ebuild b/dev-python/six/six-9999.ebuild
new file mode 100644
index 000000000000..409423aecb78
--- /dev/null
+++ b/dev-python/six/six-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/six/six-9999.ebuild,v 1.1 2013/01/01 16:04:55 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} )
+
+#if LIVE
+EHG_REPO_URI="https://bitbucket.org/gutworth/six"
+
+inherit mercurial
+#endif
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://bitbucket.org/gutworth/six http://pypi.python.org/pypi/six"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+#if LIVE
+SRC_URI=
+KEYWORDS=
+#endif
+
+python_prepare_all() {
+ # disable tests that require tkinter
+ sed -i -e "s/test_move_items/_&/" test_six.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ py.test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/ )
+
+ distutils-r1_python_install_all
+}