summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-09-03 20:51:27 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-09-03 20:51:27 +0000
commite330f795648b55f412926a74d86a5fc13278cb33 (patch)
treecab283a9bd8e1739ff4d35a9c8643568d54761d4 /dev-python/snakeoil
parentchange dependency from virtual/tetex to virtual/texi2dvi and prevent installa... (diff)
downloadgentoo-2-e330f795648b55f412926a74d86a5fc13278cb33.tar.gz
gentoo-2-e330f795648b55f412926a74d86a5fc13278cb33.tar.bz2
gentoo-2-e330f795648b55f412926a74d86a5fc13278cb33.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/ChangeLog7
-rw-r--r--dev-python/snakeoil/snakeoil-0.3.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/snakeoil/ChangeLog b/dev-python/snakeoil/ChangeLog
index d422332a65c7..be2fa3269edb 100644
--- a/dev-python/snakeoil/ChangeLog
+++ b/dev-python/snakeoil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/snakeoil
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.11 2008/03/18 21:49:37 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.12 2008/09/03 20:51:27 jokey Exp $
+
+*snakeoil-0.3 (03 Sep 2008)
+
+ 03 Sep 2008; Markus Ullmann <jokey@gentoo.org> +snakeoil-0.3.ebuild:
+ Version bump
*snakeoil-0.2 (18 Mar 2008)
diff --git a/dev-python/snakeoil/snakeoil-0.3.ebuild b/dev-python/snakeoil/snakeoil-0.3.ebuild
new file mode 100644
index 000000000000..69270247de8e
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-0.3.ebuild,v 1.1 2008/09/03 20:51:27 jokey Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="Miscellaneous python utility code."
+HOMEPAGE="http://www.pkgcore.org/"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DOCS="AUTHORS NEWS"
+DEPEND="!<sys-apps/pkgcore-0.4.7.8"
+RDEPEND=${DEPEND}
+
+# Uses an ugly hack to install for all versions of python on the
+# system. This should be supported through the eclass at some point.
+# pkgcore needs it now to support upgrading to a different python slot.
+
+src_compile() {
+ local opython=${python}
+ for python in /usr/bin/python2.[4-9]; do
+ distutils_src_compile
+ done
+ python=${opython}
+}
+
+src_test() {
+ local opython=${python} tempdir
+ for python in /usr/bin/python2.[4-9]; do
+ tempdir="${T}/tests/$(basename ${python})"
+ mkdir -p "${tempdir}" || die "tempdir creation failed"
+ cp -r "${S}" "${tempdir}" || die "test copy failed"
+ cd "${tempdir}/${P}"
+ "${python}" setup.py test || die "testing returned non zero"
+ done
+ python=${opython}
+ rm -rf "${T}/tests"
+}
+
+src_install() {
+ local opython=${python}
+ for python in /usr/bin/python2.[4-9]; do
+ distutils_src_install
+ done
+}