summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-11-10 16:38:26 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-11-10 16:38:26 +0000
commit7dbd98f558e72696457a0b0efb64ec0134680845 (patch)
tree4b8490f907db4a045a89ba1eeb832bcfc2c87d7a /dev-python/spyder/spyder-1.0.1.ebuild
parentold (diff)
downloadgentoo-2-7dbd98f558e72696457a0b0efb64ec0134680845.tar.gz
gentoo-2-7dbd98f558e72696457a0b0efb64ec0134680845.tar.bz2
gentoo-2-7dbd98f558e72696457a0b0efb64ec0134680845.zip
Version bump, thanks to David Voge <davidvoge@gmail.com> (bug #292564)
(Portage version: 2.2_rc49/cvs/Linux i686)
Diffstat (limited to 'dev-python/spyder/spyder-1.0.1.ebuild')
-rw-r--r--dev-python/spyder/spyder-1.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/spyder/spyder-1.0.1.ebuild b/dev-python/spyder/spyder-1.0.1.ebuild
new file mode 100644
index 000000000000..acb5eba0be2e
--- /dev/null
+++ b/dev-python/spyder/spyder-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-1.0.1.ebuild,v 1.1 2009/11/10 16:38:26 grozin Exp $
+EAPI=2
+NEED_PYTHON=2.5
+inherit distutils
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/"
+SRC_URI="http://spyderlib.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="matplotlib mayavi numpy pylint scipy"
+
+RDEPEND=">=dev-python/PyQt4-4.4
+ >=dev-python/qscintilla-python-2.1
+ matplotlib? ( dev-python/matplotlib )
+ mayavi? ( sci-visualization/mayavi:2 )
+ numpy? ( dev-python/numpy )
+ pylint? ( dev-python/pylint )
+ scipy? ( sci-libs/scipy )"