summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 20:38:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-13 20:38:35 +0000
commitce2f901b1b6282a3011c4f6c7a07b584a9aac4f1 (patch)
treefda39ee74fc2ffd6ffa7d33ca7cf20952bcdb8df /dev-python/spyder
parentstable ppc, bug 341311 (diff)
downloadgentoo-2-ce2f901b1b6282a3011c4f6c7a07b584a9aac4f1.tar.gz
gentoo-2-ce2f901b1b6282a3011c4f6c7a07b584a9aac4f1.tar.bz2
gentoo-2-ce2f901b1b6282a3011c4f6c7a07b584a9aac4f1.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/files/spyder-2.0.3-disable_sphinx_dependency.patch51
-rw-r--r--dev-python/spyder/spyder-1.1.8.ebuild29
-rw-r--r--dev-python/spyder/spyder-2.0.3.ebuild57
3 files changed, 0 insertions, 137 deletions
diff --git a/dev-python/spyder/files/spyder-2.0.3-disable_sphinx_dependency.patch b/dev-python/spyder/files/spyder-2.0.3-disable_sphinx_dependency.patch
deleted file mode 100644
index 10c7d302c032..000000000000
--- a/dev-python/spyder/files/spyder-2.0.3-disable_sphinx_dependency.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- setup.py
-+++ setup.py
-@@ -13,7 +13,6 @@
-
- from distutils.core import setup
- from distutils.command.build import build
--from sphinx import setup_command
- import os, os.path as osp, sys
-
-
-@@ -36,24 +35,6 @@
- splist.append(".".join(dirpath.split(os.sep)))
- return splist
-
--# Sphinx build (documentation)
--class MyBuild(build):
-- def has_doc(self):
-- setup_dir = os.path.dirname(os.path.abspath(__file__))
-- return os.path.isdir(os.path.join(setup_dir, 'doc'))
-- sub_commands = build.sub_commands + [('build_doc', has_doc)]
--
--class MyBuildDoc(setup_command.BuildDoc):
-- def run(self):
-- build = self.get_finalized_command('build')
-- sys.path.insert(0, os.path.abspath(build.build_lib))
-- dirname = self.distribution.get_command_obj('build').build_purelib
-- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
-- setup_command.BuildDoc.run(self)
-- sys.path.pop(0)
--
--cmdclass = {'build': MyBuild, 'build_doc': MyBuildDoc}
--
-
- NAME = 'spyder'
- LIBNAME = 'spyderlib'
-@@ -80,7 +61,7 @@
- get_package_data(LIBNAME, ('.qm', '.svg', '.png', '.css')),
- 'spyderplugins':
- get_package_data('spyderplugins', ('.qm', '.svg', '.png'))},
-- requires=["pyflakes (>0.3.0)", "rope (>0.9.0)", "sphinx (>0.6.0)",
-+ requires=["pyflakes (>0.3.0)", "rope (>0.9.0)",
- "PyQt4 (>4.3)"],
- scripts=['spyder.pyw', 'spyder.py'] if os.name == 'nt' else ['spyder'],
- classifiers=['License :: OSI Approved :: MIT License',
-@@ -94,5 +75,4 @@
- 'Programming Language :: Python :: 2.7',
- 'Development Status :: 5 - Production/Stable',
- 'Topic :: Scientific/Engineering',
-- 'Topic :: Software Development :: Widget Sets'],
-- cmdclass=cmdclass)
-+ 'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/spyder-1.1.8.ebuild b/dev-python/spyder/spyder-1.1.8.ebuild
deleted file mode 100644
index 4ac08e758def..000000000000
--- a/dev-python/spyder/spyder-1.1.8.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-1.1.8.ebuild,v 1.1 2010/10/23 20:41:01 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit distutils
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
-SRC_URI="http://spyderlib.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="matplotlib mayavi numpy pylint scipy"
-
-RDEPEND=">=dev-python/PyQt4-4.4[webkit]
- >=dev-python/qscintilla-python-2.1
- matplotlib? ( dev-python/matplotlib )
- mayavi? ( sci-visualization/mayavi:2 )
- numpy? ( dev-python/numpy )
- pylint? ( dev-python/pylint )
- scipy? ( sci-libs/scipy )"
-
-PYTHON_MODNAME="spyderlib spyderplugins"
diff --git a/dev-python/spyder/spyder-2.0.3.ebuild b/dev-python/spyder/spyder-2.0.3.ebuild
deleted file mode 100644
index 70f6a2e9edc0..000000000000
--- a/dev-python/spyder/spyder-2.0.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/spyder/spyder-2.0.3.ebuild,v 1.2 2010/12/06 18:34:12 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="http://code.google.com/p/spyderlib/ http://pypi.python.org/pypi/spyder"
-SRC_URI="http://spyderlib.googlecode.com/files/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ipython matplotlib numpy +pyflakes pylint +rope scipy"
-
-RDEPEND=">=dev-python/PyQt4-4.4[webkit]
- ipython? ( dev-python/ipython )
- matplotlib? ( dev-python/matplotlib )
- numpy? ( dev-python/numpy )
- pyflakes? ( >=dev-python/pyflakes-0.3 )
- pylint? ( dev-python/pylint )
- rope? ( >=dev-python/rope-0.9.0 )
- scipy? ( sci-libs/scipy )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-PYTHON_MODNAME="spyderlib spyderplugins"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-disable_sphinx_dependency.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="build-$(PYTHON -f --ABI)" sphinx-build doc doc_output || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd doc_output > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}