summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-30 01:35:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-30 01:35:11 +0000
commit323c82cd532acb9eaec542e868afd1ef4dd4244b (patch)
treef247ac7645cd204197a7f0149d186e472d3aea3d /dev-python/twisted-words
parentVersion bump (bug #294924). (diff)
downloadgentoo-2-323c82cd532acb9eaec542e868afd1ef4dd4244b.tar.gz
gentoo-2-323c82cd532acb9eaec542e868afd1ef4dd4244b.tar.bz2
gentoo-2-323c82cd532acb9eaec542e868afd1ef4dd4244b.zip
Version bump (bug #294924).
(Portage version: 14920-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/twisted-words')
-rw-r--r--dev-python/twisted-words/ChangeLog8
-rw-r--r--dev-python/twisted-words/twisted-words-9.0.0.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/twisted-words/ChangeLog b/dev-python/twisted-words/ChangeLog
index 0c8eae69b287..b0039a3e9df7 100644
--- a/dev-python/twisted-words/ChangeLog
+++ b/dev-python/twisted-words/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/twisted-words
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/ChangeLog,v 1.40 2009/11/29 13:18:22 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/ChangeLog,v 1.41 2009/11/30 01:35:11 arfrever Exp $
+
+*twisted-words-9.0.0 (30 Nov 2009)
+
+ 30 Nov 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +twisted-words-9.0.0.ebuild:
+ Version bump (bug #294924).
29 Nov 2009; Mounir Lamouri <volkmar@gentoo.org>
twisted-words-8.2.0.ebuild:
diff --git a/dev-python/twisted-words/twisted-words-9.0.0.ebuild b/dev-python/twisted-words/twisted-words-9.0.0.ebuild
new file mode 100644
index 000000000000..c5ecb231fed7
--- /dev/null
+++ b/dev-python/twisted-words/twisted-words-9.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-words/twisted-words-9.0.0.ebuild,v 1.1 2009/11/30 01:35:11 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+MY_PACKAGE="Words"
+
+inherit twisted
+
+DESCRIPTION="Twisted Words contains Instant Messaging implementations."
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-$(get_version_component_range 1)*
+ =dev-python/twisted-web-$(get_version_component_range 1)*"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="twisted/plugins twisted/words"
+
+src_install() {
+ twisted_src_install
+
+ # Remove the "im" script, because we do not depend on the required pygtk.
+ rm -fr "${D}"usr/{bin,share/man}
+}