summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-04-23 08:48:42 +0000
committerFabian Groffen <grobian@gentoo.org>2010-04-23 08:48:42 +0000
commit0546e0641aa95ea37cc7122265c88d943496af05 (patch)
tree4c4a6695bbb5607ebf694085763d869b3528cbc9 /dev-python/twisted
parentVersion bump, bug #316661, thank Justin Lecher for report. (diff)
downloadgentoo-2-0546e0641aa95ea37cc7122265c88d943496af05.tar.gz
gentoo-2-0546e0641aa95ea37cc7122265c88d943496af05.tar.bz2
gentoo-2-0546e0641aa95ea37cc7122265c88d943496af05.zip
Fix src_test for Prefix, thanks Dan Wallis in bug #316739
(Portage version: 2.2.00.15842-prefix/cvs/SunOS i386)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog5
-rw-r--r--dev-python/twisted/twisted-10.0.0.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 17edd0948fa2..2c7024138ef5 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/twisted
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.127 2010/03/17 10:39:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.128 2010/04/23 08:48:42 grobian Exp $
+
+ 23 Apr 2010; Fabian Groffen <grobian@gentoo.org> twisted-10.0.0.ebuild:
+ Fix src_test for Prefix, thanks Dan Wallis in bug #316739
*twisted-10.0.0 (17 Mar 2010)
diff --git a/dev-python/twisted/twisted-10.0.0.ebuild b/dev-python/twisted/twisted-10.0.0.ebuild
index 40f26c4d4191..c60ff83c8be3 100644
--- a/dev-python/twisted/twisted-10.0.0.ebuild
+++ b/dev-python/twisted/twisted-10.0.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-10.0.0.ebuild,v 1.1 2010/03/17 10:39:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-10.0.0.ebuild,v 1.2 2010/04/23 08:48:42 grobian Exp $
-EAPI="2"
+EAPI="3"
SUPPORT_PYTHON_ABIS="1"
inherit eutils distutils versionator
@@ -46,7 +46,7 @@ src_test() {
local return_status="0"
"$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${T}/tests" --no-compile || die "Installation of tests failed with Python ${PYTHON_ABI}"
- pushd "${T}/tests$(python_get_sitedir)" > /dev/null || die
+ pushd "${T}/tests${EPREFIX}$(python_get_sitedir)" > /dev/null || die
# Skip broken tests.
rm -f twisted/python/test/test_release.py
@@ -58,7 +58,7 @@ src_test() {
# docstrings in all packages
echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
- if ! PYTHONPATH="." "${T}/tests/usr/bin/trial" twisted; then
+ if ! PYTHONPATH="." "${T}/tests${EPREFIX}/usr/bin/trial" twisted; then
if [[ -n "${TWISTED_DEBUG_TESTS}" ]]; then
die "Tests failed with Python ${PYTHON_ABI}"
else
@@ -102,7 +102,7 @@ src_install() {
update_plugin_cache() {
# Update dropin.cache only when Twisted is still installed.
- if [[ -f "${ROOT%/}${EPREFIX}$(python_get_sitedir)/twisted/plugin.py" ]]; then
+ if [[ -f "${EROOT%/}$(python_get_sitedir)/twisted/plugin.py" ]]; then
einfo "Regenerating plugin cache with Python ${PYTHON_ABI}"
# http://twistedmatrix.com/documents/current/core/howto/plugin.html
"$(PYTHON)" -c "from twisted.plugin import IPlugin, getPlugins; list(getPlugins(IPlugin))"