summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-09-13 13:58:10 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-09-13 13:58:10 +0000
commitee5901623c2f678d111242a059da39fc74dd1b18 (patch)
treeca02fdbebe185a907d0a89644169e967c7774843 /dev-python/twisted
parentversion bump (diff)
downloadgentoo-2-ee5901623c2f678d111242a059da39fc74dd1b18.tar.gz
gentoo-2-ee5901623c2f678d111242a059da39fc74dd1b18.tar.bz2
gentoo-2-ee5901623c2f678d111242a059da39fc74dd1b18.zip
version bump
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog6
-rw-r--r--dev-python/twisted/Manifest4
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.71
-rw-r--r--dev-python/twisted/twisted-1.0.7.ebuild43
4 files changed, 51 insertions, 3 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 45e3a1d12c31..8cea0416b8b5 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.23 2003/08/30 04:37:26 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.24 2003/09/13 13:58:03 lordvan Exp $
+*twisted-1.0.7 (13 Sep 2003)
+ 13 Sep 2003; Thomas Raschbacher <lordvan@gentoo.org> twisted-1.0.7.ebuild:
+ version bump
+
*twisted-1.0.7-rc1 (30 Aug 2003)
30 Aug 2003; Thomas Raschbacher<lordvan@gentoo.org>:
removed alpha5
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index 54b68e548763..0ee6b570cf8b 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -1,8 +1,8 @@
MD5 890a242f603b2a6bedfa33b97a3f3d76 twisted-1.0.6.ebuild 1219
MD5 59755b7789d4ef04a04c902b9b01d3be twisted-1.0.7_rc1.ebuild 1262
-MD5 b1d637b358d3a8154a18acefa899fbc3 ChangeLog 6401
+MD5 cdf3981a48ea8bd4708f61f8b55124de ChangeLog 6524
MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
-MD5 890a242f603b2a6bedfa33b97a3f3d76 twisted-1.0.7.ebuild 1219
+MD5 2489975a899a1d3dc7468c8e84613431 twisted-1.0.7.ebuild 1218
MD5 7b72afa2517437dbde778c70b4e19af2 files/digest-twisted-1.0.6 67
MD5 c4224a2ac969db93d73848f95579cbab files/digest-twisted-1.0.7 67
MD5 784d7af8d65cba1fa9405b7072ada41b files/digest-twisted-1.0.7_rc1 70
diff --git a/dev-python/twisted/files/digest-twisted-1.0.7 b/dev-python/twisted/files/digest-twisted-1.0.7
new file mode 100644
index 000000000000..f73225d6979c
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.7
@@ -0,0 +1 @@
+MD5 f180e39731317aaf9b9b36497018ad9c Twisted-1.0.7.tar.bz2 5229998
diff --git a/dev-python/twisted/twisted-1.0.7.ebuild b/dev-python/twisted/twisted-1.0.7.ebuild
new file mode 100644
index 000000000000..971e95e69584
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.7.ebuild,v 1.1 2003/09/13 13:58:03 lordvan Exp $
+
+inherit distutils
+
+DESCRIPTION="collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 alpha sparc"
+IUSE="gtk2 doc"
+
+DEPEND=">=dev-lang/python-2.2*
+ >=dev-python/pycrypto-1.9_alpha4
+ gtk? ( =dev-python/pygtk-0.6* )
+ gtk2? ( >=dev-python/pygtk-1.99* )"
+
+S=${WORKDIR}/Twisted-${PV}
+
+src_install() {
+ distutils_src_install
+
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+
+ # next few lines will install docs: 9.4 megs!
+ if [ -n "`use doc`" ]; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ cp -r . ${D}/usr/share/doc/${PF}
+ fi
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+}