summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2013-06-14 08:48:18 +0000
committerSven Wegener <swegener@gentoo.org>2013-06-14 08:48:18 +0000
commit3d72928813d788427d29b32c90389d0be7ee9149 (patch)
tree198d4d5bcacd17014a9b7ec4be236ce576e2d12a /dev-python/ujson
parentrevbump; migrate -> distutils-r1 (diff)
downloadgentoo-2-3d72928813d788427d29b32c90389d0be7ee9149.tar.gz
gentoo-2-3d72928813d788427d29b32c90389d0be7ee9149.tar.bz2
gentoo-2-3d72928813d788427d29b32c90389d0be7ee9149.zip
Version bump.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/ujson')
-rw-r--r--dev-python/ujson/ChangeLog7
-rw-r--r--dev-python/ujson/ujson-1.33.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/ujson/ChangeLog b/dev-python/ujson/ChangeLog
index 1e0c800774dd..4264080a9e8d 100644
--- a/dev-python/ujson/ChangeLog
+++ b/dev-python/ujson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ujson
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ujson/ChangeLog,v 1.2 2013/04/08 14:33:13 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ujson/ChangeLog,v 1.3 2013/06/14 08:48:18 swegener Exp $
+
+*ujson-1.33 (14 Jun 2013)
+
+ 14 Jun 2013; Sven Wegener <swegener@gentoo.org> +ujson-1.33.ebuild:
+ Version bump.
*ujson-1.30-r1 (08 Apr 2013)
diff --git a/dev-python/ujson/ujson-1.33.ebuild b/dev-python/ujson/ujson-1.33.ebuild
new file mode 100644
index 000000000000..8d8defb660ae
--- /dev/null
+++ b/dev-python/ujson/ujson-1.33.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ujson/ujson-1.33.ebuild,v 1.1 2013/06/14 08:48:17 swegener Exp $
+
+EAPI="5"
+
+# One test; FAIL: test_encodeToUTF8 (__main__.UltraJSONTests) under py2.5.
+# Fix and repair and re-insert if it's REALLY needed
+PYTHON_COMPAT=( python{2_6,2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="http://pypi.python.org/pypi/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ # See setup.py; line 72. Again "${S}" is used for reading tests
+ # Since py3_2 is first in the queue it needs its own copy
+ # or else all py2s to follow will be reading read py3 tests
+ if [[ "${EPYTHON}" == 'python3.2' ]]; then
+ cd "${BUILD_DIR}"/lib || die
+ cp -a "${S}"/tests/ . || die
+ 2to3 -w tests/tests.py
+ "${PYTHON}" tests/tests.py || die
+ rm -rf tests/ || die
+ else
+ "${PYTHON}" tests/tests.py || die
+ fi
+}