summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-06 13:55:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-06 13:55:15 +0000
commit2cdfc963f60f6eb30df891c0a270aeb0a4c5d5ec (patch)
tree94fb740c134343a2ed5dadc84c4bb25c23881392 /dev-python/unittest2
parentapp-misc/enum: Bump to 1.0.2 (diff)
downloadgentoo-2-2cdfc963f60f6eb30df891c0a270aeb0a4c5d5ec.tar.gz
gentoo-2-2cdfc963f60f6eb30df891c0a270aeb0a4c5d5ec.tar.bz2
gentoo-2-2cdfc963f60f6eb30df891c0a270aeb0a4c5d5ec.zip
Support Python 3.
(Portage version: 2.2.0_alpha7_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/unittest2')
-rw-r--r--dev-python/unittest2/ChangeLog6
-rw-r--r--dev-python/unittest2/unittest2-0.5.1.ebuild24
2 files changed, 23 insertions, 7 deletions
diff --git a/dev-python/unittest2/ChangeLog b/dev-python/unittest2/ChangeLog
index 2ec62ed0fdd5..0bdbf4bbecb5 100644
--- a/dev-python/unittest2/ChangeLog
+++ b/dev-python/unittest2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/unittest2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/ChangeLog,v 1.11 2010/11/16 17:42:04 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/ChangeLog,v 1.12 2010/12/06 13:55:15 arfrever Exp $
+
+ 06 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ unittest2-0.5.1.ebuild:
+ Support Python 3.
16 Nov 2010; Thomas Kahle <tomka@gentoo.org> unittest2-0.5.1.ebuild:
x86 stable per bug 345487
diff --git a/dev-python/unittest2/unittest2-0.5.1.ebuild b/dev-python/unittest2/unittest2-0.5.1.ebuild
index 30725e9e29a4..9c425d8c6032 100644
--- a/dev-python/unittest2/unittest2-0.5.1.ebuild
+++ b/dev-python/unittest2/unittest2-0.5.1.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/unittest2-0.5.1.ebuild,v 1.6 2010/11/16 17:42:04 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/unittest2-0.5.1.ebuild,v 1.7 2010/12/06 13:55:15 arfrever Exp $
EAPI="3"
-PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="The new features in unittest for Python 2.7 backported to Python 2.4+."
-HOMEPAGE="http://pypi.python.org/pypi/unittest2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/unittest2 http://pypi.python.org/pypi/unittest2py3k http://code.google.com/p/unittest-ext/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ mirror://pypi/${PN:0:1}/${PN}py3k/${PN}py3k-${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -21,11 +20,24 @@ IUSE=""
DEPEND="dev-python/setuptools"
RDEPEND="${DEPEND}"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
DOCS="README.txt"
+src_prepare() {
+ preparation() {
+ if [[ "${PYTHON_ABI}" == 3.* ]]; then
+ cp -pr "${WORKDIR}/${PN}py3k-${PV}" "${S}-${PYTHON_ABI}" || return 1
+ else
+ cp -pr "${S}" "${S}-${PYTHON_ABI}" || return 1
+ fi
+ }
+ python_execute_function -q preparation
+}
+
src_test() {
testing() {
./unit2 discover
}
- python_execute_function testing
+ python_execute_function -s testing
}