summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 14:18:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 14:18:31 +0000
commit77bd4853264a7005df3593617bf32372543e9c1f (patch)
tree9a4dfeca95f694f11b9bd0ecb8d19c7bab9f043f /dev-python/urwid
parentRemove ruby19 from USE_RUBY since it does not build with Ruby 1.9. (diff)
downloadgentoo-2-77bd4853264a7005df3593617bf32372543e9c1f.tar.gz
gentoo-2-77bd4853264a7005df3593617bf32372543e9c1f.tar.bz2
gentoo-2-77bd4853264a7005df3593617bf32372543e9c1f.zip
Bump to 0.9.8.3
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/urwid')
-rw-r--r--dev-python/urwid/ChangeLog9
-rw-r--r--dev-python/urwid/urwid-0.9.8.3.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 1eab64432da4..d2d2bc1d6475 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/urwid
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.23 2007/06/24 19:11:17 lucass Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.24 2009/02/15 14:18:31 patrick Exp $
+
+*urwid-0.9.8.3 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org> +urwid-0.9.8.3.ebuild:
+ Bump to 0.9.8.3
*urwid-0.9.8.1 (24 Jun 2007)
diff --git a/dev-python/urwid/urwid-0.9.8.3.ebuild b/dev-python/urwid/urwid-0.9.8.3.ebuild
new file mode 100644
index 000000000000..5cb7d3c0f9e1
--- /dev/null
+++ b/dev-python/urwid/urwid-0.9.8.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.8.3.ebuild,v 1.1 2009/02/15 14:18:31 patrick Exp $
+
+NEED_PYTHON=2.2
+
+inherit distutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_test() {
+ "${python}" test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins bigtext.py browse.py calc.py dialog.py edit.py
+ doins fib.py graph.py input_test.py tour.py
+ fi
+}