summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-12-02 01:07:30 +0000
committerTim Harder <radhermit@gentoo.org>2011-12-02 01:07:30 +0000
commitfcdefa91bc6dcc15cc9277f67cb3a936b40ca134 (patch)
treef471c5c1903bc29d5baa68b3714bb19c3484dce2 /dev-python/urwid
parentVersion bump (diff)
downloadgentoo-2-fcdefa91bc6dcc15cc9277f67cb3a936b40ca134.tar.gz
gentoo-2-fcdefa91bc6dcc15cc9277f67cb3a936b40ca134.tar.bz2
gentoo-2-fcdefa91bc6dcc15cc9277f67cb3a936b40ca134.zip
Version bump.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/urwid')
-rw-r--r--dev-python/urwid/ChangeLog7
-rw-r--r--dev-python/urwid/urwid-1.0.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 111491a3faa4..a2699db25375 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.45 2011/11/04 22:30:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.46 2011/12/02 01:07:30 radhermit Exp $
+
+*urwid-1.0.1 (02 Dec 2011)
+
+ 02 Dec 2011; Tim Harder <radhermit@gentoo.org> +urwid-1.0.1.ebuild:
+ Version bump.
04 Nov 2011; Markos Chandras <hwoarang@gentoo.org> urwid-1.0.0.ebuild:
Fix dependencies. Restrict Jython ABIs. Ignore tests failures with Python 3.1.
diff --git a/dev-python/urwid/urwid-1.0.1.ebuild b/dev-python/urwid/urwid-1.0.1.ebuild
new file mode 100644
index 000000000000..2d2e05a6b83c
--- /dev/null
+++ b/dev-python/urwid/urwid-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-1.0.1.ebuild,v 1.1 2011/12/02 01:07:30 radhermit Exp $
+
+EAPI="4"
+PYTHON_USE_WITH="ncurses"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+PYTHON_TESTS_FAILURES_TOLERANT_ABIS="3.1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python"
+HOMEPAGE="http://excess.org/urwid/ http://pypi.python.org/pypi/urwid"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_install() {
+ distutils_src_install
+
+ dohtml reference.html tutorial.html
+
+ if use examples; then
+ docinto examples
+ dodoc bigtext.py browse.py calc.py dialog.py edit.py \
+ fib.py graph.py input_test.py tour.py
+ fi
+}