summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-11 13:24:02 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-11-11 13:24:02 +0000
commitee4a1fd40722e6befe482fb11af624c85211d81e (patch)
treea9584edc7ecc12e42e21a74aaf0ec8db80bae4e2 /dev-python/visual
parentkeyword ~ppc, bug #442318 (diff)
downloadgentoo-2-ee4a1fd40722e6befe482fb11af624c85211d81e.tar.gz
gentoo-2-ee4a1fd40722e6befe482fb11af624c85211d81e.tar.bz2
gentoo-2-ee4a1fd40722e6befe482fb11af624c85211d81e.zip
Keyword ~ppc for 5.74, remove 5.4, bug #442318
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-python/visual')
-rw-r--r--dev-python/visual/ChangeLog6
-rw-r--r--dev-python/visual/visual-5.4.ebuild75
-rw-r--r--dev-python/visual/visual-5.74.ebuild4
3 files changed, 7 insertions, 78 deletions
diff --git a/dev-python/visual/ChangeLog b/dev-python/visual/ChangeLog
index 2e7746b7959b..d9c1abb404f5 100644
--- a/dev-python/visual/ChangeLog
+++ b/dev-python/visual/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/visual
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.61 2012/07/07 19:19:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.62 2012/11/11 13:24:02 blueness Exp $
+
+ 11 Nov 2012; Anthony G. Basile <blueness@gentoo.org> -visual-5.4.ebuild,
+ visual-5.72-r2.ebuild, visual-5.74.ebuild:
+ Keyword ~ppc for 5.74, remove 5.4, bug #442318
07 Jul 2012; Mike Gilbert <floppym@gentoo.org>
+files/visual-5.74-boost-1.50.patch, visual-5.74.ebuild:
diff --git a/dev-python/visual/visual-5.4.ebuild b/dev-python/visual/visual-5.4.ebuild
deleted file mode 100644
index a772d54fa23a..000000000000
--- a/dev-python/visual/visual-5.4.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.4.ebuild,v 1.9 2012/05/04 15:12:14 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit flag-o-matic multilib python versionator
-
-MY_P="${PN}-$(delete_version_separator 2)_release"
-
-DESCRIPTION="Real-time 3D graphics library for Python"
-HOMEPAGE="http://www.vpython.org/"
-SRC_URI="http://www.vpython.org/contents/download/${MY_P}.tar.bz2"
-
-IUSE="doc examples"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-LICENSE="visual"
-
-RDEPEND="<dev-libs/boost-1.48[python]
- dev-cpp/libglademm
- >=dev-cpp/gtkglextmm-1.2
- dev-python/numpy"
-# dev-python/polygon
-# >=dev-python/ttfquery-1.0.4
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- echo "#!/bin/bash" > py-compile
- python_src_prepare
-}
-
-src_configure() {
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.41.0")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
-
- # We have to use a hack here because the build system doesn't provide a way to specify
- # the include and lib directory for boost.
- append-cxxflags -I${BOOST_INC}
- append-ldflags -L${BOOST_LIB}
-
- python_src_configure \
- --with-html-dir=/usr/share/doc/${PF}/html \
- --with-example-dir=/usr/share/doc/${PF}/examples \
- $(use_enable doc docs) \
- $(use_enable examples)
-}
-
-src_install() {
- python_src_install
- python_clean_installation_image
-
- dodoc authors.txt HACKING.txt NEWS.txt || die "dodoc failed"
-
- # Don't install useless vpython script.
- rm -fr "${ED}usr/bin"
-}
-
-pkg_postinst() {
- python_mod_optimize vis visual
-}
-
-pkg_postrm() {
- python_mod_cleanup vis visual
-}
diff --git a/dev-python/visual/visual-5.74.ebuild b/dev-python/visual/visual-5.74.ebuild
index aee4e14bb694..ed01ede9b8f1 100644
--- a/dev-python/visual/visual-5.74.ebuild
+++ b/dev-python/visual/visual-5.74.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.74.ebuild,v 1.3 2012/07/07 19:19:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.74.ebuild,v 1.4 2012/11/11 13:24:02 blueness Exp $
EAPI="4"
SUPPORT_PYTHON_ABIS="1"
@@ -17,7 +17,7 @@ SRC_URI="http://www.vpython.org/contents/download/${MY_P}.tar.bz2"
LICENSE="visual"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc examples"
RDEPEND=">=dev-cpp/gtkglextmm-1.2