summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-02 16:23:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-02 16:23:11 +0000
commit58eaf65a5228970f1d8d1569ea0da9af34879c4c (patch)
tree974b96ae34910e0576ac9d7b93763f8c81e43b43 /dev-python/vo
parentAURA was BSD, so removing again (diff)
downloadgentoo-2-58eaf65a5228970f1d8d1569ea0da9af34879c4c.tar.gz
gentoo-2-58eaf65a5228970f1d8d1569ea0da9af34879c4c.tar.bz2
gentoo-2-58eaf65a5228970f1d8d1569ea0da9af34879c4c.zip
Initial import to the main tree
(Portage version: 2.2_rc72/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/vo')
-rw-r--r--dev-python/vo/ChangeLog48
-rw-r--r--dev-python/vo/files/vo-0.6-expat.patch19
-rw-r--r--dev-python/vo/metadata.xml12
-rw-r--r--dev-python/vo/vo-0.6.ebuild37
4 files changed, 116 insertions, 0 deletions
diff --git a/dev-python/vo/ChangeLog b/dev-python/vo/ChangeLog
new file mode 100644
index 000000000000..4b85e63e01e4
--- /dev/null
+++ b/dev-python/vo/ChangeLog
@@ -0,0 +1,48 @@
+# ChangeLog for dev-python/vo
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vo/ChangeLog,v 1.1 2010/09/02 16:23:11 bicatali Exp $
+
+ 02 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org> +vo-0.6.ebuild,
+ +files/vo-0.6-expat.patch, +metadata.xml:
+ Initial import to the main tree
+
+ 17 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org> vo-0.5.ebuild,
+ vo-0.6.ebuild:
+ Update HOMEPAGE
+
+*vo-0.6 (21 Jul 2010)
+
+ 21 Jul 2010; Sébastien Fabbro <bicatali@gentoo.org> +vo-0.6.ebuild,
+ +files/vo-0.6-expat.patch:
+ Version bump
+
+ 26 Jun 2010; Justin Lecher <jlec@gentoo.org> vo-0.5.ebuild:
+ Python ABI fixes
+
+ 28 Apr 2010; Kacper Kowalik <xarthisius.kk@gmail.com> vo-0.5.ebuild,
+ +files/vo-0.5-assertion_fix.patch, +files/vo-0.5-skiptests.patch:
+ Skipping failing tests, fixing assertion.
+
+ 28 Apr 2010; Kacper Kowalik <xarthisius.kk@gmail.com> -files/vo-0.3.1-docs.patch,
+ vo-0.5.ebuild, +files/vo-0.5-docs.patch, +files/vo-0.5-expat.patch:
+ Removing doc USE flags, since they're no longer building, adding missing
+ test dependencies, using new style for Python.
+
+*vo-0.5 (12 Feb 2010)
+
+ 12 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org> -vo-0.4.ebuild,
+ +vo-0.5.ebuild:
+ Bump
+
+*vo-0.4 (08 Oct 2009)
+
+ 08 Oct 2009; Sébastien Fabbro <bicatali@gentoo.org> -vo-0.3.1.ebuild,
+ +vo-0.4.ebuild:
+ Version bump
+
+*vo-0.3.1 (21 Jul 2009)
+
+ 21 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +vo-0.3.1.ebuild,
+ +files/vo-0.3.1-docs.patch, +metadata.xml:
+ Initial import
+
diff --git a/dev-python/vo/files/vo-0.6-expat.patch b/dev-python/vo/files/vo-0.6-expat.patch
new file mode 100644
index 000000000000..24157f39084c
--- /dev/null
+++ b/dev-python/vo/files/vo-0.6-expat.patch
@@ -0,0 +1,19 @@
+--- defsetup.py.orig 2010-07-21 17:35:59.000000000 +0100
++++ defsetup.py 2010-07-21 17:37:06.000000000 +0100
+@@ -17,14 +17,9 @@
+
+ iterparse_ext = Extension(
+ "vo.iterparser",
+- ["src/iterparse.c",
+- "src/expat/xmlparse.c",
+- "src/expat/xmlrole.c",
+- "src/expat/xmltok.c",
+- "src/expat/xmltok_impl.c"
+- ],
++ ["src/iterparse.c"],
+ define_macros=defines,
+- include_dirs=["src", "src/expat"])
++ libraries=["expat"])
+
+ pkg = ['vo', 'vo.tests']
+ # Python < 2.6 doesn't have the json module
diff --git a/dev-python/vo/metadata.xml b/dev-python/vo/metadata.xml
new file mode 100644
index 000000000000..b0bd8b61e432
--- /dev/null
+++ b/dev-python/vo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ vo.table is a Python package to read and write astronomical VOTable
+ files into Numpy record arrays.
+ vo.table supports the VOTable Format Definition Version 1.1. Some
+ flexibility is provided to support the 1.0 draft version and other
+ non-standard usage in the wild.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/vo/vo-0.6.ebuild b/dev-python/vo/vo-0.6.ebuild
new file mode 100644
index 000000000000..b4265997aeb8
--- /dev/null
+++ b/dev-python/vo/vo-0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vo/vo-0.6.ebuild,v 1.1 2010/09/02 16:23:11 bicatali Exp $
+
+EAPI=3
+
+#PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="Python module to read VOTABLE into a Numpy recarray"
+HOMEPAGE="https://trac6.assembla.com/astrolib/wiki http://www.scipy.org/AstroLib"
+SRC_URI="http://stsdas.stsci.edu/astrolib/${P}.tar.gz"
+
+IUSE="examples"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-expat.patch
+}
+
+#FIXME: tests are buggy, sphinx misses stsci_sphinx.conf
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die
+ fi
+}